How to do a white-label embed

  • Idea
  • Updated 2 years ago
  • Implemented
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: outdated

  1. Copy the prezi code from the URL (prezi.com/[prezi-code]/prezi-name).
  2. Place the code into the following code where it says [prezi-code]
    <iframe width="550" height="400" src="http://prezi.com/[prezi-code]/view" frameborder="1" allowfullscreen></iframe>

Please note that this will only work if the person who made the prezi has a paid license or EDU Enjoy. If the maker has a Public license, the Prezi logo will appear.
Photo of gparyani

gparyani, Champion

  • 639 Posts
  • 96 Reply Likes

Posted 4 years ago

  • 9
Photo of gparyani

gparyani, Champion

  • 639 Posts
  • 96 Reply Likes
The Prezi logo will always appear while loading, no matter what license the maker has. It will disappear when loading is complete.
Photo of gparyani

gparyani, Champion

  • 639 Posts
  • 96 Reply Likes
If you're having trouble with this, please look at the replies to see if any remedies are available for your particular situation.
Photo of gparyani

gparyani, Champion

  • 639 Posts
  • 96 Reply Likes
Has anyone tried it yet? Does it work?
Photo of relliottR

relliott, Champion

  • 133 Posts
  • 28 Reply Likes
I tried it. It didn't work for me. (I'm a PreziPro, paid-license user.) Perhaps some of the code you intended is not listed. Also, for "prezi code" are you referring to the presentation ID that appears in the URL address bar during editing, or do you mean the presentation ID that appears in the embed code generated from the tool provided by Prezi? I tried it both ways.

You may be onto something, but I can't quite follow what you mean in your instructions. Can you help me to understand? Thanks.
Photo of Alex

Alex, Official Rep

  • 1950 Posts
  • 118 Reply Likes
It does work.
@Relliott try to copy the URL in the adress bar but remove the [ brackets ] from the code. I simply used the code as it is and it worked fine on my html page.

Alex
Photo of Patrick

Patrick

  • 2 Posts
  • 0 Reply Likes
i don't get it either, could you paste an example?
Photo of Patrick

Patrick

  • 2 Posts
  • 0 Reply Likes
now i got it.

get the url of your prezi you can share:
like: http://prezi.com/1234abcd/my-prezi/
the "prezi-code" is the: "1234abcd"

in the end it has to look like:

really not that complicated. :)
Photo of Paul Bowles

Paul Bowles

  • 4 Posts
  • 1 Reply Like
hate to say but this doesn't work guys....
Photo of Paul Bowles

Paul Bowles

  • 4 Posts
  • 1 Reply Like
whoops it does, my prezi numbers were all letters!!!!
Photo of Anthony DomineAD

Anthony Domine

  • 3 Posts
  • 0 Reply Likes
I followed the steps here and was unable to get it to work.... any help???
Photo of Anthony DomineAD

Anthony Domine

  • 3 Posts
  • 0 Reply Likes
Figured it out! This is great thanks
Photo of rjensenR

rjensen

  • 4 Posts
  • 0 Reply Likes
Everyone else seemed to figure out so I've worked and tried not to ask buuut I'm struggling!

Here is what I'm embedding: < iframe width="550" height="400" src="http://prezi.com/y6whhuvcxix6/view" frameborder="1" allowfullscreen>< /iframe>

I'm embedding it into a Joomla Article. The normal prezi works fine but this disappears as soon as I save... Any ideas?
Photo of rjensenR

rjensen

  • 4 Posts
  • 0 Reply Likes
ha nevermind. Had to do with Joomla's iframe issue not the code. Thanks so much! Anyone else who runs into this problem download this plugin (http://extensions.joomla.org/extensio...) for the iframe!
Photo of relliottR

relliott, Champion

  • 133 Posts
  • 28 Reply Likes
Tried it again and gparyani's fix works very well. Much cleaner than the standard embed, the presentation auto-loads, and the previous navigation bar disappears--along with the logo!.

Thanks.
Photo of NathL

NathL, Champion

  • 1276 Posts
  • 59 Reply Likes
thank you GParyani for this. This is a nice feature. Easier to understand how navigate and get fullscreen for the visitors.

but the prezi viewer has a nice frame with the shadow...

NathL :)

frenchspeakers :
retrouvez cette astuce sur http://annuaire-prezi.blogspot.com/20...
Photo of NathL

NathL, Champion

  • 1276 Posts
  • 59 Reply Likes
I've noticed that the zooming movement is better with the iframe. The embed is a little jerky,.. comparing the same prezi on the same webpage (my blog^^).
Photo of NathL

NathL, Champion

  • 1276 Posts
  • 59 Reply Likes
it's ok either with the <object> tag.

<object data="http://prezi.com/krhk589ehlp1/view" height="300" width="550"></object>
but you have to give the link at the bottom :
<div style="text-align: center;">
lien vers&nbsp;<a href="http://prezi.com/krhk589ehlp1/a-propos-de-perspective/" target="_blank" title=" (traduction du prezi de Adam Somlai-Fischer) ">à propos de perspective...</a> sur&nbsp;<a href="http://prezi.com/" target="_blank">Prezi</a>.com</div>

looks like this : http://annuaire-prezi.blogspot.fr/201...
(in french)
Photo of DeborahD

Deborah

  • 1 Post
  • 0 Reply Likes
If anyone is still struggling, the easiest way seems to be to turn off your editor (in user manager) prior to embedding.

Remember to turn it back on, but to turn it off any time you amend the article with the Prezi in it or you'll strip out the code.
Photo of Ben A.BA

Ben A.

  • 1 Post
  • 0 Reply Likes
At least with the JCE Joomla editor, there's an option not to strip out iframes upon save. Navigate thus:

Components > JCE Editor > Editor Global Configuration > Editor Profiles > Default (or whatever profile you're using) > Editor Parameters > Advanced > add "iframe" (no quotes) to the Extended Elements box. (This is also the menu where you can enable JS, CSS, PHP, and XHTML.)
Photo of Cathryne

Cathryne

  • 6743 Posts
  • 287 Reply Likes
Hej NathL!

Could there be a problem with hyperlinks when using your embed method? Please see these examples: http://www.barlett.pl/ and http://www.virtualdressingroom.pl/. Apparently, the hyper-linked logos do not load the correct URL, but add the prezi's URL before, thus breaking the link.

Thanks and greetings!
Photo of AnoushaA

Anousha

  • 3 Posts
  • 0 Reply Likes
Hello all,

Figured out how to do this but now the autoplay embedded functionality is gone! Any ideas on how I can make this work-around prezi loop back to the start? Currently you have to manually hit back arrow to go back to beginning.
Thanks!
Photo of gparyani

gparyani, Champion

  • 639 Posts
  • 96 Reply Likes
Look at my video on looping paths at http://gparyani.com/ , under My YouTube Channel.
Photo of charlotte thomasCT

charlotte thomas

  • 6 Posts
  • 0 Reply Likes
Hi,
Thanks so much for this fix, works great... on IE!
However, I need it to work on firefox... I have a fully up to date version.
I don't receive any error messages - the prezi just simply doesn't show up - it cannot be seen
Any ideas?
Thanks in advance!
Photo of DanD

Dan

  • 17 Posts
  • 2 Reply Likes
This is a great fix. So much cleaner, faster, and easier for the end user!!! Many thanks!!!

It is funny that iframe at one time was considered really old hat. It is now coming back into the main stream, even YouTube uses iframes.

Come on Prezi... This fix should be standard, NOT what is being used now .

Note: Only use the code which consists of numbers and letters from the prezi URL link. DO NOT use the whole URL.

Photo of DanD

Dan

  • 17 Posts
  • 2 Reply Likes
Charlotte,

I am running latest version of IE, FF, and Chrome.

It works great in all browsers. I did notice that IE will not show if it is private. I had to set to public to have it show.
Photo of Iggy ReillyIR

Iggy Reilly

  • 38 Posts
  • 2 Reply Likes
Hi there -- I've been using this trick a couple of time fine, and just now I get an error message within the iframe saying “You don't have the required permission to view this page”; does the trick still work?

I know the code is right (because I was able to see the prezi before I logged out from my account), and I checked on a page where I know people could see it fine a couple of weeks ago, and I get the same message.

TIA.
Photo of gparyani

gparyani, Champion

  • 639 Posts
  • 96 Reply Likes
You have to make sure that the prezi is public in order for it to work.
Photo of Iggy ReillyIR

Iggy Reilly

  • 38 Posts
  • 2 Reply Likes
Thanks gparyani. Is this new? I would have sworn that it use to work even with private prezis...
Photo of Laurita Moore

Laurita Moore

  • 9 Posts
  • 1 Reply Like
Yep! Got it to work.
Photo of Iggy ReillyIR

Iggy Reilly

  • 38 Posts
  • 2 Reply Likes
Without making it public?
Photo of Laurita Moore

Laurita Moore

  • 9 Posts
  • 1 Reply Like
I have an EDU account so mine are all public.
Photo of Cathryne

Cathryne

  • 6743 Posts
  • 287 Reply Likes
They don't have to be ;-)
All EDU licenses include the option to make prezis private.
Photo of Iggy ReillyIR

Iggy Reilly

  • 38 Posts
  • 2 Reply Likes
They don't have to be public in order for the white-label hack to work?
Photo of Laurita Moore

Laurita Moore

  • 9 Posts
  • 1 Reply Like
Thank for the reminder. I have some in process and test Prezi's lying around that I should take off public view.
Photo of Angela

Angela

  • 1 Post
  • 0 Reply Likes
Hi, I'm still struggling with making this work.

I've put together the code

What do I do with this code now in order to embed it onto my company's website? Everything I've tried hasn't worked...

Any help would be great!
Photo of Laurita Moore

Laurita Moore

  • 9 Posts
  • 1 Reply Like
Used it in class this week with about 100 students to embed their Prezis in their sites. Worked fine. Thanks for the save. The embed process associated with the embed button no longer works for us. Why is that?

This conversation is no longer open for comments or replies.