how to embed prezi in wordpress.com blog

  • Problem
  • Updated 3 days ago
  • Solved
Yes, I have read the prezi manual.
Yes, I have made my prezi public.
Yes, I have copied the embed code to clipboard.
Yes, I have pasted the embed code into the html view of the wordpress blog page.
No, the code doesn't embed and disappears in full from the entire screen when the post is saved.
Photo of teri abelTA

teri abel

  • 5 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 32
Photo of Zoli Radnai

Zoli Radnai, Official Rep

  • 5939 Posts
  • 311 Reply Likes
Hi, is it the same with other embed codes (like youtube) as well? The Prezi blog also runs on Wordpress engine, and I can embed prezis without any problems.

there might be an issue with your blog cms?
Photo of teri abelTA

teri abel

  • 5 Posts
  • 0 Reply Likes
I'm pretty sure I can't embed video as my blog stands. The wordpress people just sent me this: I'm sorry but some types of code are not allowed here at WordPress.com. The code you are trying to add is a flash embed and it is not allowed.
http://en.support.wordpress.com/code/...

The only option we have that you may be able to use to embed a presentation would be scribd. Here is some information about that:
http://en.support.wordpress.com/scribd/ "
Photo of adorján.viktorA

adorján.viktor

  • 1 Post
  • 0 Reply Likes
according to this http://en.support.wordpress.com/code/ the embed object iframe codes are not allowed on wordpress.com this might cause the problem
Photo of marticanipeM

marticanipe

  • 1 Post
  • 0 Reply Likes
I had the same problem, but when I emailed WordPress support I got this response:
"> Is it possible that WordPress will support the embedding of prezi
> files anytime in the (very) near future.
>
> Thanks!

I'll add it to our list of suggestions, in the meantime there is a possiblity that you can post them using Vodpod:

http://support.wordpress.com/videos/v...

Thanks,

Hanni"

I tried this and it worked! It is a multi-step process, but I did achieve the desired resut, my prezi in my wordpress blog.

Good Luck!
Photo of aaronphaneufA

aaronphaneuf

  • 1 Post
  • 0 Reply Likes
The trick is to paste the 'embed' code into the Vodpod dialogue box. Initially, it didn't find my prezi, but then asked if I had the embedded code - YES - so I pasted it in and BAM, I've got a Prezi presentation on my blog - aaronphaneuf.wordpress.com Thanks for the help y'all.
Photo of Marc

Marc

  • 9 Posts
  • 1 Reply Like
Hiya

I installed this plug-in on Word Press and Prezi is working fine.

http://wordpress.rebelic.nl/prezi-sho...
Photo of teri abelTA

teri abel

  • 5 Posts
  • 0 Reply Likes
Thanks Marc!
Photo of teri abelTA

teri abel

  • 5 Posts
  • 0 Reply Likes
Thanks all!
Photo of Morten Blaabjerg

Morten Blaabjerg

  • 39 Posts
  • 2 Reply Likes
Marc, thanks, but that plugin works only on an independent wordpress install, which is very good, but doesn't solve the original problem. The embed still won't work with a regular http://wordpress.com/ blog as there's no way to add the plugin.
Photo of isabelgonzalez1I

isabelgonzalez1

  • 1 Post
  • 0 Reply Likes
I have been able to do it by adding the Prezi to Vodpod and then embed the video-vodpod to the Wordpres: the embed works with a regular wordpress.com
Photo of tony.waghornT

tony.waghorn

  • 4 Posts
  • 1 Reply Like
I used Vodpod with the embed code ... I think:

http://virtualmobiliser.wordpress.com...

Yep - just checked the code. Vodpod is able to wrap the flash.
Photo of RajeshR

Rajesh

  • 5 Posts
  • 0 Reply Likes
yeah I don't see your Prezi showing up??? on your page???
Photo of Zoli Radnai

Zoli Radnai, Official Rep

  • 5939 Posts
  • 311 Reply Likes
Thanks for the feedback, Tony! This topic had been quoted in Prezis official Learn page. Thanks for the input, guys!

http://prezi.com/learn/tips-and-trick...
Photo of r.houbenR

r.houben

  • 4 Posts
  • 0 Reply Likes
I use the Prezi Shortcode plugin for Wordpress (Marc's suggestion) but I can't find the view link of my Prezi's anymore. I can only link to / embed a page like this: http://prezi.com/8en7ur8zklio/samenwe...
But I want to embed just the presentation, not everything arround it.
I supose because of the new prezi look?
any suggestion's?
Photo of ben.p.holdenB

ben.p.holden

  • 2 Posts
  • 0 Reply Likes
Greetings,

Thanks for the help so far. I'm using the Prezi Shortcode plugin but, as you can see... www.fleetfootstudios.com ... it has embedded the entire page.

Is there any way to just embed the prezi itself?
Photo of Roel

Roel, Champion

  • 1905 Posts
  • 368 Reply Likes
Ben,

Looks like you pasted the code recieved when clicking on 'link' instead of the code recieved when clicking on 'embed'.
Am I correct?

Hope this helps,

Kind regards,

Roel
(Fellow user, not affiliated with the prezi team).
Photo of r.houbenR

r.houben

  • 4 Posts
  • 0 Reply Likes
I don't use the Prezi Shortcode plugin any more. It's more easy to copy the embed code from Prezi, put the edit mode from Wordpress in HTML and past de embed code there.
This is the result:
http://rob-houben.dacapo-college.nl/w...
Photo of ben.p.holdenB

ben.p.holden

  • 2 Posts
  • 0 Reply Likes
Amazing. Thanks mate.
Photo of cedric gavillet

cedric gavillet

  • 1 Post
  • 0 Reply Likes
Hi everyone, i've tried the vodpod trick for my wordpress.com blog, but it doesn't work. i subscribed, put the widget on my blog, and when i "add a video" in vodpod, with the embed code of my prezi, vodpod writes : "sorry, we do not support videos from that site"
Have i forgotten one step, or do you think this is vodpod which has blocked this trick ?

Thanks for the answers, and have a nice day all ! Cédric
Photo of bookbagdesignerB

bookbagdesigner

  • 9 Posts
  • 4 Reply Likes
Hi Cedric

I tried the same too. Seems that vodpod had recently disabled that ability to add prezis.

Their reply
"Sorry, but our mission at Vodpod is to help people specifically collect videos. We don’t support other Flash objects like presentations or slideshows."

http://vodpod.com/forums/2/topics/1391

Anyone else has any good solutions?
Photo of MarkM

Mark

  • 1 Post
  • 0 Reply Likes
Thanks for the help so far. I'm using the Prezi Shortcode plugin but, as you can see... it has embedded the entire page. spyhunter 4 crack
Photo of carlos.constanzaC

carlos.constanza

  • 2 Posts
  • 0 Reply Likes
Hey all!
Prezi works like a charm, helping me a lot in my presentations... but I'm having some issues with Autoplay and Hide Controls when embedding int Wordpress. I want my Prezis to autoplay on loadComplete.

First on the FlashVars:
{param name="flashvars" value="prezi_id=cxrlvpytjfb9&lock_to_path=0&color=ffffff&autoplay=no&autohide_ctrls=0"/}

And on Embed Code:
{embed flashvars="prezi_id=cxrlvpytjfb9&lock_to_path=0&color=ffffff&autoplay=no&autohide_ctrls=0"}

It isn't working when I switch it to 'yes' and '1'. Is there any workaround?

Thanks in advance!
Photo of carlodileoC

carlodileo

  • 2 Posts
  • 0 Reply Likes
Carlos, have you figured this out yet? I am having the exact same issue.
Photo of corrijoC

corrijo

  • 2 Posts
  • 1 Reply Like
Same here Carlos!
Photo of bookbagdesignerB

bookbagdesigner

  • 9 Posts
  • 4 Reply Likes
Hi all,

I solved it, for me at least! Now my Prezi runs smoothly on my wordpress.com blog. Note, it's the FREE wordpress.COM blog, not self-hosted/paid-hosting wordpress.ORG blogs. I'm not sure how things would work on the .org blogs, but I presume if this works on the the wordpress.com blogs, it should also work on the wordpress.org blogs. I used "gigya" flash hacks for this, thanks to Panos of wordpress tips blog here:
http://wpbtips.wordpress.com/2010/07/...

1. My Prezi is on [http://prezi.com/8c_glvg9xaur/the-boo.... I got the HTML embed code from the </> icon. I won't paste it here as it'll show up as the Prezi itself!

2. Extract the middle portion of the code (shown below) and paste on a text editor document (like MS word):

src="http://prezi.com/bin/preziloader.swf" type="application/x-shockwave-flash" allowfullscreen="true" allowscriptaccess="always" width="550" height="400" bgcolor="#ffffff" flashvars="prezi_id=8c_glvg9xaur&lock_to_path=0&color=ffffff&autoplay=no&autohide_ctrls=0"

3. Edit the "EXTRACTED CODE" by adding "[gigya" before and "]" after the "EXTRACTED CODE", like this:

[gigya src="http://prezi.com/bin/preziloader.swf" type="application/x-shockwave-flash" allowfullscreen="true" allowscriptaccess="always" width="550" height="400" bgcolor="#ffffff" flashvars="prezi_id=8c_glvg9xaur&lock_to_path=0&color=ffffff&autoplay=no&autohide_ctrls=0"]

4. Paste this short code onto your the wordpress.com blog post while in HTML/Visual editor mode, and it should show up nicely after you publish!
Photo of rafaelR

rafael

  • 1 Post
  • 0 Reply Likes
Great ! Txs so much.
Photo of David Anthony Alves

David Anthony Alves

  • 1 Post
  • 0 Reply Likes
Dude, you're a fuggen genius.
Photo of valerie.wireV

valerie.wire

  • 2 Posts
  • 0 Reply Likes
Okay, so I'm following this instructions and they're working great! My only problem now is that whenever I go to view it, I'm greeted with a little blurb after the Prezi embedding loads that says "This Prezi does not exist" ... and it does.

Any ideas?
Photo of Cathryne

Cathryne

  • 6743 Posts
  • 287 Reply Likes
Hi Valerie,

did you maybe change the public/private setting for the prezi after generating the embed code? If you let me know the URLs of the prezi, and the website, I can investigate further.

Kind regards,

Katrin
Photo of Dan S. Rossiter

Dan S. Rossiter

  • 4 Posts
  • 1 Reply Like
You'll have a much easier time just using Prezi Embedder (http://wordpress.org/extend/plugins/prezi-embedder).
Photo of nnanddN

nnandd

  • 1 Post
  • 0 Reply Likes
Thank you so much, bookbagdesigner!!!!

I searched too much for discovered a solution and only yours answer realy solved my problem. Thankyou!

The result: http://fernandamourao.wordpress.com/b...
Photo of ezE

ez

  • 3 Posts
  • 0 Reply Likes
bookbagdesigner you are great.
I tried all morning to solve it (only after 4-5 hours i noticed your comment).
and then it took about 10 seconds.

i suggest Prezi guys to help us a bit more and just put a title like this in the FAQ section:
How to embed a Prezi in WordPress:
Get your PREZI_ID let's say XXX
Embed the code below to the blog editor
That's it!!!
[gigya src="http://prezi.com/bin/preziloader.swf" type="application/x-shockwave-flash" allowfullscreen="true" allowscriptaccess="always" width="550" height="400" bgcolor="#ffffff" flashvars="prezi_id=XXX&lock_to_path=0&color=ffffff&autoplay=no&autohide_ctrls=0"]

you can even go further with supplying an embedding form asking the following:
autoplay: Y/N
autohide_ctrls: Y/N
allowfullscreen: Y/N
allowscriptaccess: Y/N
after the checkboxing is complete just supply the code.
Photo of Alexandra M. Korey

Alexandra M. Korey

  • 1 Post
  • 0 Reply Likes
thanks bookbagdesigner. Oddly enough, I edited the code as you suggested but it didn't work for m... I wonder if things have changed again. I'm using a self hosted wordpress, and the whole code just gets stripped, whereas with this edited code you suggest, it shows up as text (of course i'm entering it in the html editor :-) ). Oh well!
Photo of Communication Design

Communication Design

  • 5 Posts
  • 0 Reply Likes
Finally!!!! Thank you all for working this out.
Photo of applxperienceA

applxperience

  • 29 Posts
  • 2 Reply Likes
I think wordpress is trying to "fix" your code.
Did you try to paste the code and UPDATE the post WITHOUT changing to visual view?
If you left blank lines before and after the code, WP could try to put it inside a paragraph, and fix whatever is necessary to make the tags closing consistent (even "fixing" your embed code)

Make sure previous tags are properly closed too.

It happened the same to be before, and it was wordpress not linking some tags inside others, e.g. em inside strong, so I had to "learn" what WP was going to change and do it its way so it stops doing it.

Does that gigya hack makes the prezi presentation to automatically play?
Mine sits pre-loaded with a GIANT white box on top of the whole top half of the presentation with the presentation's name and description. I tried autostart everywhere, no success.
Photo of Communication Design

Communication Design

  • 5 Posts
  • 0 Reply Likes
For me it worked with the gigya, just copied it with the ID of the Prezi and done.

I pasted it in visual mode and in HTML mode, it doesn't seem to really affect the whole thing.
Photo of applxperienceA

applxperience

  • 29 Posts
  • 2 Reply Likes
The OP already stated to have pasted the code in both visual and HTML mode.

My question, again, is:

DId you try NOT switching views ( HTML / Visual ) after you pasted the content?

Switching between views does the same "code fixing" you want to avoid, NO MATTER WHICH VIEW you pasted it in.

Also, did you use ANY text editor before to past it into wordpress?
Some apps, and some browser plugins, some javascript "copy to clipboard" scripts, and others CONVERT the quotation marks to "pretty" ones, instead of the regular ones you need in coding. Even website programmers upload the wrong ones themselves to workaround database and programming issues.

Did you verify the quotation marks are correct? (not specially left or right ones)
Photo of Communication Design

Communication Design

  • 5 Posts
  • 0 Reply Likes
I don't think it reaaly matters because when you update or publish your post WP also "fixes" your code, which by the way can be a pain.

If I'm right, I pasted it in visual mode, then updated and saw the preview, then went to HTML mode to fix something somewhere else....

But since it already works I don't think it's such a big deal! Next time I'll pay more attention to the exact proccess :)
Photo of applxperienceA

applxperience

  • 29 Posts
  • 2 Reply Likes
There are changes that wp DOES fix at saving, even if you didn't switch views after pasting, and things it doesn't fix.

I don't remember exactly which ones, but in my last test (about last year?) I definitely found things that STAY when visual view tab is not clicked.