description column width in investment register cannot be reduced in size

  • 0
  • 1
  • Problem
  • Updated 2 weeks ago
  • Acknowledged
The columns widths in the investment register appear to be able to be reduced in size except for the Description column.  In fact, I can reduce the size of the other columns so that the data in them is truncated.  Why doesn't the description column behave like the other columns.
Please fix.
Photo of Mike - Deluxe 2017 R17.4 (Win)

Posted 6 months ago

  • 0
  • 1
Photo of UKR

UKR, SuperUser

  • 407,504 Points 100k badge 2x thumb
I'm already on Q 2018. For me, the minimum width of the Description column appears to be about 2.5 inches. Can't make it any smaller, but at my screen size and resolution (17" laptop), that's just fine.

What do you get?
How wide is your Quicken window?
What is your screen size and resolution?
Are you perhaps using View / Use large fonts?
Photo of mshiggins

mshiggins, SuperUser

  • 402,522 Points 100k badge 2x thumb
From C. D. Bales:

Contrary to your claim, the "description column" in investment accounts most certainly can be reduced in size.

But, like every other column in all Quicken accounts, the description column in investment accounts can not be reduced below a certain size (no difference from earlier versions - except those which did not allow any adjustment to the width of account columns).

There is no fixed size limit that applies to every column in Quicken accounts: the minimum size of different columns is different - but all account columns can be reduced ... until they reach their minimum limit.

I can't speak to the actual limit on the minimum width of any column in any Quicken account, but I can say that there has always been a limit on the minimum size of columns in Quicken accounts.

You are not seeing anything new.
That is incorrect.  The other columns can be reduced in size so that only a couple characters of data is displayed in them.  The description column cannot be reduced so that only a couple of columns of characters are displayed.
Compare the column widths I was able to reduce in size to the description column width

(Edited)
Photo of mshiggins

mshiggins, SuperUser

  • 402,500 Points 100k badge 2x thumb
That is the minimum size for the Description column. The column can be reduced in size, it just can't be reduced beyond the minimum size - as you have found.
Photo of petermic

petermic

  • 302 Points 250 badge 2x thumb
So.  Any relief on this issue?  Is it better in Quicken 2019?  It is so annoying.

My description column never gets filled, even with it at minimum size - about half the column is empty space. 

Then there are the other columns that needlessly occupy a lot of valuable screen space.  I don't need the attachment column or the left hand one with the blue dot.   I don't need the Inv. Amt or the Cash Bal.   What I do need is a reasonable window size.


Folks, it's not 1998 any more!    As it is I have to expand the Quicken window way beyond what I need or any other application, just to provide it with enough empty space.
Photo of speedlever

speedlever

  • 1,274 Points 1k badge 2x thumb
I just upgraded from QP2016 to QP2019 and ran into this issue with the investment register. I can adjust the column width of any column EXCEPT the description column in the investment register. As a result, I cannot see the contents in the rightmost column (cash bal) without scrolling the screen (19 inch monitor... 1280x1024). I have minimized the column widths for both [attachments] and [clr] to the minimum, else I would be unable to see the rightmost 2 columns.

I did not have this issue on QP2016. I am amazed this is an ongoing, known problem.
(Edited)
Photo of QPW

QPW

  • 369,102 Points 100k badge 2x thumb
For what it is worth the reason it fit before in Quicken 2016 and doesn't now is because they went to a slightly different font, which is slightly wider than what they were using.

And as you can see from this screenshot for some transaction types there isn't a lot of blank space.


I tried with 1280x1024 and I think you are going to have to go with Jim Harman's suggestion and hide the account bar.

Personally think they should set the minimum to a smaller amount.  Yes that will truncate some text in some cases, but that is already true of the other fields and as such something that the user can play with the trade offs.

This one of those kinds of problems that is extremely easy for the developer to change, but probably just doesn't get changed because they have a long list of bugs to work on and it just doesn't get any priority.
Photo of speedlever

speedlever

  • 1,274 Points 1k badge 2x thumb
Interesting. Well, I'm willing to experiment. How exactly do I hide the account bar? Is that the account list on the left side of the screen? If so, that's not an attractive option either.

Edit: I notice I can click the down arrow and get the full screen long enough to see what I want. I'd really prefer it to go back to how it was in 2016.

(Also looking at my 15.6" 1080p laptop screen)... same issue.
(Edited)
Photo of QPW

QPW

  • 369,102 Points 100k badge 2x thumb



Note there is also a trick of using the collapsed Account bar.

Clearly you can click on the same triangle icon to un-collapse it, but if you click on ACCOUNTS it will show the account bar, and after you click on an account it will collapse it automatically.
Photo of Jim Harman

Jim Harman, SuperUser

  • 27,674 Points 20k badge 2x thumb
The Description field has a minimum width because for some transactions (Buy and Sell, e.g.) that space holds multiple fields when the transaction is selected.

To make more room for the transaction list, try clicking on the edge of the Account Bar when the double arrows appear and dragging to make it narrower. Also you can hide the Account Bar by clicking on the little triangle to the left of the word ACCOUNTS. Click it again to make it reappear.
Photo of Jim Harman

Jim Harman, SuperUser

  • 27,674 Points 20k badge 2x thumb
Also depending on your eyesight, you may want to make the fonts smaller. In Windows 10, right-click on the desktop, click on Display Settings and set the Windows font size to "100% (Recommended)"
Photo of speedlever

speedlever

  • 1,274 Points 1k badge 2x thumb
The older I get, the less I Iike small fonts!

Regarding the description field, I don't recall it being an issue with QP2016. Why would it change from how it worked there? Of course, now that I upgraded, I can't bring up 2016 to compare.
(Edited)
Photo of speedlever

speedlever

  • 1,274 Points 1k badge 2x thumb
"To make more room for the transaction list, try clicking on the edge of the Account Bar when the double arrows appear and dragging to make it narrower. "

This will reduce the info available on the left side of the screen, which is also unacceptable. I prefer the option to reduce the size of the description field.

Wish I could bring up QP2016 and see how that was handled there.
Photo of Jim Harman

Jim Harman, SuperUser

  • 27,674 Points 20k badge 2x thumb
I can understand wanting to use large fonts. Are yours set larger than 100%?

For me the widest field is the Security name, and that can be made much narrower than the default without hiding the names of most securities. Note that you don't have to use the official names for your securities, Quicken uses the ticker and CUSIP number to match to quotes and downloads, so you can shorten the names so they take up less space if that helps.

Also Christmas is coming and these days you can get a 24" 1920x1080 monitor for about $130 - less than the cost of a new pair of glasses!
Photo of speedlever

speedlever

  • 1,274 Points 1k badge 2x thumb
Lol. Well, I use 100% on my 19" x 2 monitors and 125% (default) on my 15.6 1080p laptop screen (both show the same amount of info).

Won't the description field wrap like the security field? I don't have any description fields with enough info to wrap. For now, I've chosen to reduce the size of the security field, as you suggested. But the greatest amount of unused space lives in that description field. That's the one I'd prefer to wrap.

Also, I've already customized the names of the securities anyway.
(Edited)
Photo of QPW

QPW

  • 369,102 Points 100k badge 2x thumb
I personally run two (used to be three before one died.) 28" monitors at 1920x1200.
(No "large fonts" and at 100%).  But of course with my glasses these days (has been true since I was about 45, I'm no 61, and the glasses just keep getting stronger)
Photo of speedlever

speedlever

  • 1,274 Points 1k badge 2x thumb
Haha. I could certainly go for a 3rd monitor and put it to good use. I have to slide my glasses out somewhat just to see the screens clearly these days. Probably time for a prescription change.

My laptop screen is hard for me to read. But I don't want to enlarge the print anymore and loose more detail on the page. So I just struggle with it for now.

Getting old is heck... but it sure beats the alternative!
Photo of QPW

QPW

  • 369,102 Points 100k badge 2x thumb
Wrapping only works up to a point.


You have to realize that all the other fields are "single" (actually when selected some like the security field are "two", but the description is actually up to 5 fields.  And it is this fact that lets the security and others wrap in the first place.


Photo of speedlever

speedlever

  • 1,274 Points 1k badge 2x thumb
Good to know. Since the description field is up to 5 fields, I would thing that would be a natural one to wrap.
Photo of QPW

QPW

  • 369,102 Points 100k badge 2x thumb
You can't "wrap fields", only the text in them.  They are trying to cram a lot of information in a very small area.
Photo of speedlever

speedlever

  • 1,274 Points 1k badge 2x thumb
Gotcha. Thanks.