Downloaded transactions in Quicken Premier 2018 for Windows error message "Please Enter Valid Date".

  • 0
  • 8
  • Problem
  • Updated 2 months ago
  • Solved
Cannot "accept" or enter any downloaded transactions in to Register.  Continue to get "Please Enter Valid Date".  I enter valid date with a 4 digit year and clears field and shows error message dialogue box again.  Started entry of a transaction on new line and it was able to be entered.  Is anyone else having this issue with downloaded transactions?
Photo of BigKev

BigKev

  • 270 Points 250 badge 2x thumb

Posted 6 months ago

  • 0
  • 8
Photo of UKR

UKR, SuperUser

  • 377,466 Points 100k badge 2x thumb

What kind of a Date format are you using? US mm/dd/yyyy e.g., 10/29/2017 or something else?

The Date format is controlled by the settings in Windows Control Panel, Region, Short Date.

What bank are you downloading from?


Can you please capture one or more images of the parts of your Quicken window showing the issue, redacted as necessary to protect your privacy but annotated to describe the situation, and attach the image(s) here?
The Windows Snipping Tool (available with Windows 7 and up) can be used to capture a partial screen image and save it to a file.  Microsoft Paint can be used to annotate the image.
To take a screenshot in Mac please see https://support.apple.com/en-us/HT201361
Please create image files of type PNG, JPG or BMP only.
To attach the image here, start composing your reply. At the bottom of the text entry window you'll see a row of icons beginning with B I U S
Click the camera icon (not the video camera icon). It will allow you to select and upload the captured image file from your computer. The captured image will be inserted at wherever the cursor is located in the text.

Photo of BigKev

BigKev

  • 270 Points 250 badge 2x thumb
Thanks for the quick reply.  I just re-booted Quicken and went back in to capture the screen images and the transactions were accepted.  So, I guess it was an odd bug or something.  Thanks again.
Photo of Tim Marciniak

Tim Marciniak

  • 166 Points 100 badge 2x thumb
Every time I try to change a downloaded transaction date I get that error too.
Photo of BigKev

BigKev

  • 270 Points 250 badge 2x thumb
Hey Tim...in Windows 10 I went to Control Panel and chose Region.  In that menu I changed the date format to MM/dd/yyyy (mine was set to M/dd/yyyy) and the transactions started being accepted.  Hope that works for you.
Photo of Tim Marciniak

Tim Marciniak

  • 166 Points 100 badge 2x thumb
Thanks! We'll see at the next download. I like my transactions to have the date we incurred the expense not the day it posted.
Photo of UKR

UKR, SuperUser

  • 375,786 Points 100k badge 2x thumb

Tim,
you said: "I like my transactions to have the date we incurred the expense not the day it posted."

In that case you need to enter all your transactions manually before downloading from the bank. The bank can only give you the Posting Date, i.e., the date that the bank received your transaction for processing ... which can be 1 or more days after you made your purchase.
If Quicken receives a downloaded transaction which matches an existing register entry it will match the two together without changing the transaction date in the register.

Photo of Bob

Bob

  • 294 Points 250 badge 2x thumb
Not quite true that "The bank can only give you the Posting Date." Some banks do actually download the transaction date, though the majority of banks I deal with download the posting date. There is no consistency.
When I enter the transaction regardless of the bank  It does not show as entered, if I repeat the entry then tells to enter valid date and does not accept my efforts to enter the date, then close the account, reopen and there it is the transaction and it ask me to match and then it is accepted. This is totally unacceptable
Photo of bcbeatty

bcbeatty

  • 278 Points 250 badge 2x thumb
I just downloaded Q2018, and I'm on Windows 10. I also get this error.
It's preventing me from accepting any downloaded transactions.
My windows date format is already M/d/yyyy.

Considering this is a 3 month old bug. I would have expected this to be fixed.
Photo of Clayton

Clayton

  • 6,432 Points 5k badge 2x thumb
"I like my transactions to have the date we incurred the expense not the day it posted."

I manually enter ALL my transactions and then match them up with the download. I opted to use both the Date Column AND the Posting Date Column. In Quicken 2018 for Windows select it in the Register View, click the gear icon and go down to Register Columns.

Please excuse me if I'm telling you something you already know.
(Edited)
Photo of Vickie

Vickie

  • 302 Points 250 badge 2x thumb
I'm also seeing this issue with downloaded transactions.  When I try to accept a New transaction, it appears on a second line in the register with no date at all.  Then when I click Accept, I get the invalid date prompt.  If I click out of the account and back in - with the same list of downloaded transactions - then I can accept the new items.  However, other changes are no longer recognized.  For example, if I update an existing entry for the corrected amount to match a downloaded transaction, it no longer recognizes that it matches unless I switch accounts and back again.   Once it is in this state, it will affect multiple accounts with waiting downloaded entries.  The only way to truly reset and get it back to 'normal' is to close the program completely and re-open.  I have noticed this several times since I upgraded to 2018.  I use Home, Business & Rental version of Quicken.  
Photo of UKR

UKR, SuperUser

  • 377,466 Points 100k badge 2x thumb

If your Quicken 2018 hasn't updated itself to release 5.15 yet (or even if it already has), please try this:

Go to https://www.quicken.com/support/update-and-mondo-patch-2018-release-quicken-windows
Locate the US or Canada Mondo Patch file applicable to your version of Quicken in the links above.
Download it and save it to disk.
Temporarily disable your Antivirus software for the entire duration of the next step:
- Open the Downloads folder. Right-click the downloaded patch file. Click "Run as Administrator" to execute the installation program.
 

Please let me know if that resolves your Invalid Date issue.

(Edited)
Photo of bcbeatty

bcbeatty

  • 278 Points 250 badge 2x thumb
That appears to be working thanks
Photo of UKR

UKR, SuperUser

  • 377,466 Points 100k badge 2x thumb

Good to hear that you're OK now.
There has been a lot of this going on with this issue ...

;-)

Photo of bcbeatty

bcbeatty

  • 278 Points 250 badge 2x thumb
Bad news, the problem is still happening
Photo of Vickie

Vickie

  • 302 Points 250 badge 2x thumb
I updated to 5.15 the other day & the issue continued after the update.  Today, I installed the Mondo patch and so far the issue has not continued.  However, most of my accounts are already updated so not many downloaded transactions have been processed yet.  Time will tell if it is truly resolved.
Photo of Vickie

Vickie

  • 302 Points 250 badge 2x thumb
Still happening after installing the Mondo patch.  Opened Quicken tonight, a few transactions downloaded and again I got the error.  When the downloaded transaction is being added to the register, it is one line below where I expect it to be...there is a blank row between the last transaction and the new one.  When it works successfully, the new transaction is in the bottom row and as it is being accepted, it moves to the row below and then up into the register.  See this screenshot for an example.  The Deposit item was previously accepted in my last Quicken session.  The Taco Bell transaction was newly downloaded tonight.  Note the blank 2/5/18 row between them...



If I click Accept with the new transaction in this position, the date field will clear and the Please Enter Valid Date prompt.  The transaction does actually get written to the register but it still appears in the downloaded transaction list too.  Switching to a different account or closing Quicken & reopening will then match the transaction.
Photo of bcbeatty

bcbeatty

  • 278 Points 250 badge 2x thumb
Bad news, the problem is still happening, I think it occurs when I haven't accepted downloaded transactions and then I download again
Photo of bcbeatty

bcbeatty

  • 278 Points 250 badge 2x thumb
It's actually worse now. If i "Accept All" it will duplicate any transaction I tried to match
Photo of UKR

UKR, SuperUser

  • 377,214 Points 100k badge 2x thumb

I'd try to reinstall Quicken clean, to see if it's a problem with how the latest software update installed itself.
If that doesn't resolve the issue, contact Quicken Support and get it escalated.


Uninstall / QCLEANUI / Reinstall

I recommend you uninstall the current Quicken and remove all remnants of older Quicken versions following this procedure, using a Windows User Account with full Administrator privileges:
http://www.quicken.com/support/using-qcleanui-uninstall-quicken
If you have previously used this procedure and have the cleanup programs already on your hard drive ... please download them again to obtain the most recent version.
When done, reboot your computer and then reinstall Quicken from your CD or saved downloaded installation file and allow it to update to the latest available patch release level. Your Antivirus software needs to be temporarily disabled for the entire duration of the installation and update process.
 

Photo of Kelly

Kelly

  • 132 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Accepting Transactions.

This reply was created from a merged topic originally titled Accepting Transactions.When I accept a transaction, whether I make any changes for not, the date will disappear & I get an error saying "enter valid date".  It will not accept any date, whether I use the calendar or type it in manually.  On the rare occasion that it will accept, it adds the transaction, but in the downloaded section, it still shows "new", not accepted.  I have to then match manually to take care of it.  This is on the new Quicken 2018.

Note: This conversation was created from a reply on: New bug in Q 2018 "Please enter a valid date"?.
Photo of Kathy B

Kathy B

  • 84 Points 75 badge 2x thumb
Am following this thread because this continues to happen as I use Quicken Deluxe R5.20 
Very frustrating. It does seem that I can "Accept All" and the transactions populate. But I prefer to review, edit and accept one transaction at a time. 

Has a fix has been identified?     ...other than uninstalling. Not sure I want to do that until I KNOW that it would fix the problem. 

This conversation is no longer open for comments or replies.