FIND Defaults

  • 0
  • 5
  • Idea
  • Updated 1 month ago
  • (Edited)
Why doesn't Quicken just fix this "FIND" issue and default to "ANY FIELD", instead of "Date"? Or allow the user to select the defaults for the "FIND" function!  I don't want to have to have/move the cursor into a field to force this selection in the "FIND" option.  Set this up as an option for the USER, not QUICKEN!  I'm using Quicken 2017 Deluxe running under Windows 10 Pro.
Photo of Dog_Man

Dog_Man

  • 476 Points 250 badge 2x thumb

Posted 10 months ago

  • 0
  • 5
Photo of Quicken Tamara

Quicken Tamara, Employee

  • 196,374 Points 100k badge 2x thumb
There are multiple "find" options in Quicken 2017.

The search box at the very top right of the program, just to the left of the Close/Minimize/Restore buttons, will search all fields of all transactions in all registers (payment or deposits).

The search box at the top right corner of each account register will search all fields of all transactions within that register.

Edit > Find (or Ctrl + F) is the more Advanced Search option, where the user defines the field(s) to search.
Photo of Rocket J Squirrel

Rocket J Squirrel, SuperUser

  • 55,334 Points 50k badge 2x thumb
All true. But it seems the majority of users preferred the previous default of Any Field. No one ever wants to Find a date, yet that is what generally appears because focus lands on the Date field most often.
Photo of WhatAmIMissing

WhatAmIMissing

  • 64 Points
Someone once said, if it ain't broke, don't fix it. The Intuit people apparently believe otherwise. Why didn't they just leave the search algorithm well enough alone?
Photo of Nancy Selllers

Nancy Selllers

  • 228 Points 100 badge 2x thumb
I completely agree - a function I use constantly has just become annoying and inefficient!!!!!!!    Put it back to "any field"!!   Or let the user create the default.  But "date" as a default is the worst possible choice!
Photo of Dog_Man

Dog_Man

  • 476 Points 250 badge 2x thumb
Use the Search function at the top right of screen - that function searches all fields - no other input needed except for the data you're looking for - skip the other FIND function - it's worthless, requiring so much changes to the default values.
Photo of Nancy Selllers

Nancy Selllers

  • 228 Points 100 badge 2x thumb
You are right.  It is much better.
Photo of Stephen Nazigian

Stephen Nazigian

  • 132 Points 100 badge 2x thumb
I cannot back down on this. Compared to working in the little search box, CTRL-F would be easy and Quick, quick as in Quicken. Just default it to back to search in any-field, certainly anything but date.
Photo of Jim Roche

Jim Roche

  • 100 Points 100 badge 2x thumb
I found that the investment accounts still default to any field for the find command (CTRL + F). It seems that whenever you enter any other type of account the date field is selected thereby making that the default field for the find. If you tab back once (shift + tab) it makes it so no field is highlighted. At this point when you CTRL+F the default is any field. Since I use both hands to hit CTRL+F it's not much extra for me to hit the shift + tab first.
(Edited)
Photo of smayer97

smayer97, SuperUser

  • 197,126 Points 100k badge 2x thumb
IIRC, I also believe that the default is based on the FIRST field displayed in the register OR whichever field your cursor happens to be in when you first open the FIND. So they are 2 ways to address this
  1. click on the desired field before you open the find 
  2. change the order of the fields in your register to have the field you want as a default to be the first column. This is because the cursor usually sits in the DATE field in the register when you first open it, edit and save a transactions or start a new one.
(If you find this reply helpful, please be sure to click "Like", so others will know, thanks.)
(Edited)
Photo of QPW

QPW

  • 320,638 Points 100k badge 2x thumb
In the Windows version, for the most part you can't change the order of the fields.
Photo of Dog_Man

Dog_Man

  • 476 Points 250 badge 2x thumb
So - using your method, how do you search for "ALL FIELDS"?
Photo of PeterB

PeterB

  • 104 Points 100 badge 2x thumb
Thank you smayer97!!  #1 is correct - click in the field you want to search and then use the CTRL-F Find function. Works for me!
Photo of Jim Roche

Jim Roche

  • 100 Points 100 badge 2x thumb
When you enter most accounts the date field is selected so when you execute the find command it searches only the date field. If you tab back once (Shift + TAB) no fields are selected therefore when you execute the find command ANY FIELD shows up.
Photo of Dog_Man

Dog_Man

  • 476 Points 250 badge 2x thumb
Just fix the default to be "ANY FIELD"!  How difficult can this be?  Or set up a parameter to be changed per user!

Here's the line of code for you too:  "Move 'Any Field' to Find-Select".  Can't get any easier than that!
(Edited)
Photo of Rocket J Squirrel

Rocket J Squirrel, SuperUser

  • 55,294 Points 50k badge 2x thumb
Wow, what is that, COBOL?
Photo of Dog_Man

Dog_Man

  • 476 Points 250 badge 2x thumb
No it's Free Form RPG IV - you probably don't know what that is!
Photo of Stephen Nazigian

Stephen Nazigian

  • 132 Points 100 badge 2x thumb
I am here looking for an answer to the same question. QD 14 always defaulted to search ANY FIELD.
Photo of Dog_Man

Dog_Man

  • 476 Points 250 badge 2x thumb
If you're on the latest version of Quicken, use the search field at the top right of the screen - this is better than the default Find function!
Photo of Rocket J Squirrel

Rocket J Squirrel, SuperUser

  • 55,294 Points 50k badge 2x thumb
RPG made me chuckle. You realize Quicken is mostly C++, right? Hailed as an OOP breakthrough when it appeared, it turned out to be one of the most error-prone languages of its time.
Photo of Jim Roche

Jim Roche

  • 100 Points 100 badge 2x thumb
When you enter most accounts the date field is selected so when you execute the find command it searches only the date field. If you tab back once (Shift + TAB) no fields are selected therefore when you execute the find command ANY FIELD shows up.
Photo of Marc Auslander

Marc Auslander

  • 212 Points 100 badge 2x thumb
I suspect the real "change" is not ignoring the selected field when it is in the empty new entry line rather than in an existing entry.  I have no issue with respecting a fields selected in an existing transaction.

As for the claim that there are other ways - by far the quickest way to search used to be (for good typists) ctrl-f, search value, alt-f.

Now the equivalent keyboard path is ctrl-f, alt-i, a, tab,tab, search value, alt-f

Come on.
Photo of Bert Love

Bert Love

  • 80 Points 75 badge 2x thumb

Just discovered that find/replace is defaulted to "Any Field"  Add this function to toolbar by right click and customize.  When using the function, don't include a replacement value and nothing happens except you find what you were looking for, in fact all of the matching transactions with newest at top.

Photo of Nancy Selllers

Nancy Selllers

  • 178 Points 100 badge 2x thumb
This appears to be the best solution!  Thank you!
Photo of Dog_Man

Dog_Man

  • 476 Points 250 badge 2x thumb
If I'm reading your reply correctly, this SEARCH function on the main line of an account only finds the transactions for that account, not all accounts.  I have stopped using the FIND function on the toolbar. which QUICKEN refuses to default to "ANY FIELD", instead of "DATE".  Instead use the SEARCH function at the top right corner of any screen.  This locates all transactions from all accounts, not just from the account currently being displayed.  Quicken employee Tamara is correct in the response given above.  It works on all fields for all transactions and stop using the generic FIND.
Photo of Jim Roche

Jim Roche

  • 100 Points 100 badge 2x thumb

I'm sure she is correct but I still use Quicken 2016. I don't like updating to the latest Quicken version until I'm forced to do so by Intuit when the stop supporting downloading.

I found this alternative in the 2016 version.

When you enter most accounts the date field is selected so when you execute the find command it searches only the date field. If you tab back once (Shift + TAB) no fields are selected therefore when you execute the find command ANY FIELD shows up.

Photo of Nancy Selllers

Nancy Selllers

  • 228 Points 100 badge 2x thumb
That is fabulous!!  Thanks so much!
Photo of Debbie Baker

Debbie Baker

  • 60 Points
That doesn't work on whatever version I'm using.  So stupid not to have it default to "Any Field."