Is Quicken Mac compatible with the new Mac OS 10.12 (Sierra)?

  • 85
  • 7
  • Article
  • Updated 7 months ago
  • (Edited)
Yes.  Both Quicken Mac 2015 and 2016 have been tested and will work on the new Sierra OS.  

Mac 2007 should work on Sierra, however, it has not been fully tested with the new OS.  See this FAQ for more information on Mac 2007 support policies.

Quicken Essentials, a discontinued product, has not been tested with Sierra, but early reports from users indicate that it is not working with Sierra.  In this case, we'd recommend not upgrading to Sierra until you upgrade your Quicken Mac product.

If you have Quicken Essentials and have already upgraded to Sierra, you can install Quicken 2016 for Mac and easily migrate your Essentials file to Quicken 2016.
Photo of Quicken Kathryn

Quicken Kathryn, Official Rep

  • 116,490 Points 100k badge 2x thumb

Posted 7 months ago

  • 85
  • 7
Photo of jang55

jang55

  • 130 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled I also have just installed Sierra and cannot access Quicken Essentials. What is ....

Quicken Essentials Vs 1.7.4   iMac OS Sierra 
Problem:   Cannot use Quicken Essentials with OS Sierra.  How do I solve this problem
Photo of toni garrett

toni garrett

  • 130 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled quicken essentials update for Sierra.

I have just updated to Sierra and cannot get into Quicken Essentials. How soon will there be an updat and how will I know?
Photo of lorri davenport

lorri davenport

  • 212 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled HAVE UPDATED TO SIERRA MAC MY OLD QUICKEN WON'T WORK NOW. THE NEW VERSION IS NO....

i HAVE UPDATED TO SIERRA FOR MAC AND MY OLD QUICKEN WON'T WORK NOW. THE NEW VERSION IS NOT AVAILABLE IN CANADA...WHAT CAN I DO TO ACCESS MY FILES
Photo of Jonathan Hart Damon

Jonathan Hart Damon

  • 130 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled NEED HELP with Quicken Essentials for MAC (needs to play nice with Sierra).

Just installed MacOS Sierra in the office, & was told that Quicken Essentials (c. 2010ish) will not operate. This will prevent me from installing at home, as my Quicken files there ARE essential. I don't need all the bells & whistles of newer versions. Is there an upgrade/bug fix to the "Essentials" package? Please? Or must I purchase more recent app? If so, will files migrate? Is current app (Quicken 2016) ready to plug & play with Sierra?
Photo of Warren Smith

Warren Smith

  • 102 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Data loss with Sierra conversion.

 If I upgrade to Quicken for Mac 16 in Sierra will it find my lost data from QUICKEN ESSENTIALS ?
Photo of Don Richardson

Don Richardson

  • 100 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Quicken essentials.

Doesn't work with Mac OS X Sierra
Photo of Don Richardson

Don Richardson

  • 100 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Quicken essentials.

Doesn't work with Mac OS X Sierra

This conversation is no longer open for comments or replies.