Q2017 Mondo Patch Fails

  • 1
  • 2
  • Problem
  • Updated 4 days ago
  • In Progress
In an effort to fix constant crashes in Q2017 RPM (mostly arising from report functions), I downloaded and attempted to install the latest mondo patch (Q2017R4MPatch.exe), even though I'm already at version R4 (build 26.1.4.5).  The patch fails with the message, "An error occurred.  Unable to check for updates, the server file failed to load."  Further details say, "Index and length must refer to a location within the string.  Parameter name: length"  All other on-line functions work; e.g., I'm able to download transactions, log into my Quicken account, etc.  Any thoughts on what's broken?

Thanks.
Photo of John L. Miller

John L. Miller

  • 1,374 Points 1k badge 2x thumb
  • perpetually annoyed

Posted 6 months ago

  • 1
  • 2
Photo of QPW

QPW

  • 307,438 Points 100k badge 2x thumb
It sounds like for some reason the patch install is corrupted.  Or maybe just something in your setup makes it think it is.

I suggest you use this procedure to uninstall Quicken and then reinstall it.
http://quicken.intuit.com/support/help/downloading--installing--upgrading-and-converting/using-qcleanui-to-uninstall-quicken/GEN82227.html
Photo of John L. Miller

John L. Miller

  • 1,374 Points 1k badge 2x thumb
I followed the entire QCleanUI procedure to fully remove Quicken, reinstalled it, and the mondo patch still fails.
Photo of QPW

QPW

  • 307,196 Points 100k badge 2x thumb
Well then I suggest you contact Quicken support.  They can at least get the logs and such from you to have a better chance at getting to the bottom of the problem.
http://www.quicken.com/contact-support Links are near the bottom of the page.
Photo of R S

R S

  • 82 Points 75 badge 2x thumb

This problem happens for every Mondo Patch that was ever released, from R1 through R5, for Quicken 2017 Real Estate on a latest Windows 10 and on a 2016 machine.  Yes, this exact problem listed above continually exists.  Quicken needs to pay attention and correct this problem.

EVEN IF the user has a so-called corrupted installation on the windows machine, a Mondo patch is there for the exact purpose of fixing a corrupted situation.  It still falls upon Quicken.

For me, since I have had Quicken 2017, a mondo patch no longer works at all, and I'm pretty upset about it.  I do not like the updates that get downloaded via One Step Update because I've had errors in the past that way and I will never trust updates given to me that way ever again.  So, for me, whenever there was an update, I went to download a Mondo Patch and then updated with that tool.  It was always trustworthy. 

I have had Quicken for the last 16 years....

Photo of QPW

QPW

  • 303,316 Points 100k badge 2x thumb
@R S you are assuming a lot of things.  First off that because you and John have had this problem everyone has it.  Far from the truth, basically if everyone had the problem this forum would light up with threads on it, and that isn't the case.

So in fact this a very rare situation, and has something to do with your exact configuration.  Hardly something that the developers would be actively trying to fix.

Also the Mondo Patch install isn't "cure all".  In fact the only difference between it and the regular install is with the regular install it checks the versions of the files that it is installing in comparison to what is on your machine, and if yours is already current, it skips it.  The Mondo patch install just overwrites all files.  So if a file that it is installing gets corrupted, that will replace it.

But that is far from the only things that can go wrong on a system.  Configuration files can be wrong (that is the reason for something like the QCleanUI procedure), permissions can be wrong on folders and files.  The installation of .Net can be corrupted...  And in fact a bad .Net configuration can be the cause of the installation program itself failing.

You might try the procedure that SuperUser thecreator suggests:

See this Article to reinstall Quicken: https://getsatisfaction.com/quickencommunity/topics/how-to-download-and-how-to-install-from-download...

Many Users, don't like Registry Cleaners, but I do and they do work.

I use Glary Utilities http://www.glarysoft.com/ 1-Click Maintenance and CCleaner
http://www.piriform.com/ccleaner

I run both Glary Utilities and CCleaner's Cleaner and Registry, right after deleting all the sub-folders and files mentioned. Saves me from restarting the computer.


After running the CCleaner, I install Quicken and it works.
Photo of Dr Tom Blinn

Dr Tom Blinn

  • 60 Points
I have been seeing exactly the same symptoms with the latest Mondo patch for Quicken 2016.  I've been through the whole "use QCLEANUI to clean up your installation and then reinstall" and it makes no difference.  There is a problem with the patch files, and it behooves Quicken (no longer part of Intuit) to address it.  If you have a problem with Quicken that needs a real patch, and you can't use the patch tool because it breaks, then effectively your Quicken product is broken.  Suggesting that you can fix the problem with some third-party "registry cleaner" that has potentially dangerous side effects is not a real solution, even though I'm sure the poster who suggested it believes it's a good idea.
Photo of Lyle Workman

Lyle Workman

  • 70 Points
Count me in on this problem too. Uninstalled per instructions twice and the mondo patch continues to fail. Definitely not good show of customer support and service Quicken!

A search of this on Google gives the best answer via StackOverflow; what ever string Quicken is using as a parameter is the wrong length. Seems some coder at Quicken should be able to fix the problem or give us a decent solution.

Once again, very bad support.
(Edited)
Photo of gmalis1

gmalis1

  • 160,180 Points 100k badge 2x thumb
All the available Mondo patches and regular patches are available here:

http://www.quicknperlwiz.com/quickenpatches.html

What happens if you unplug your internet, install Quicken and then install on older patch (the one before the Mondo patch you are trying to install)?

Does that work?
Photo of Lyle Workman

Lyle Workman

  • 70 Points
gmalis1: Thank you for lending a helping hand; Quicken owes you a debt of gratitude.

The install disk I purchased was R1; I downloaded, and installed, each of the R2 through R11 patches with success. However, either the R12 or R12 Mondo patches would work giving me the same error message "... parameter is the wrong length".

I tried using the One Step Update, however, that process stops because I have no online accounts to update and it just simply stops working.

I have successfully updated through R11 and have no idea where to go from here. If this is what can be expected from Quicken, I believe they are going to loose many customers in the future. This from a user since at least 1995, perhaps going back to 1991.

Once again, I appreciate your help and will keep an eye out for the use of your software ImportGIF.

Lyle Workman

Update: I finally was able to update to R12 through the program itself. I was forced to create an empty account and  was not able to use One Step Update to simply update the program, of no, I had to sync my file up to their cloud before it would update the program. Stuuuuuuuuupid!
(Edited)
Photo of Jeff

Jeff

  • 124 Points 100 badge 2x thumb
Downloading the Mondo patch for R11 fixed my issue where I couldn't sign-in to register after install. Presumably the hostname of the update server or something similar changed at some point.

Once I installed the R11 update I could register Quicken 2016 with no issue. Then I did a "Check for Updates" from the Help menu and Quicken successfully updated to R12.

So the patch files for Quicken 2016 R12 on Quicken's own website are broke. Why they haven't bothered to build a new set is beyond me, other than they're probably too busy working on the September patch they've announced.