Error message: "Sage is incompatible with Firefox 38.0.5"

In the Firefox "add-ons manager" I get the message "Sage is incompatible with Firefox 38.0.5". the Sage add-on status is "Disabled"

I have Sage v1.5.3.

Any ideas?
1 person has
this problem
+1
Reply