SoundManager 2.0 not working on FireFox 3.0.1

  • Question
  • Updated 2 years ago
My firefox was upgraded to FF 3.0.1 and now my sound application wont work.
I cant get SoundManager 2.0 website demos to work with this latest firefox either.
Have you ever tried it on FF 3.0.1
Photo of

  • 8 Posts
  • 2 Likes

Posted 7 years ago

  • 3
Photo of Scott

Scott, Official Rep

  • 3780 Posts
  • 241 Likes
I use Firefox 3.0.1 and it works for me. Check that you have Flash installed (maybe it needs to be reinstalled if you did a clean install of Firefox, just a guess.)

If you have some debug output from SM2 showing what's breaking, I can help you troubleshoot the issue from there. Look at the SM2 project page for example, the live debug output section at the bottom.
Photo of

  • 8 Posts
  • 2 Likes
Scott.....your magic worked again. I didn't reinstall, i just did a upgrade. So I went to Firefox -> Addons-> Plugins->Disabled Flash and then Enabled it again. Then everything starts working now. This tip might be helpful for some future reference. I dont know if you maintain a troubleshooting page. I didn't find one or else i would have posted this.
Photo of Scott

Scott, Official Rep

  • 3780 Posts
  • 241 Likes
Interesting, good to know that fixed it - I never would've thought to try actually disabling and re-enabling Flash. I'll keep this in mind in event someone else has similar problems after upgrading.
Photo of Russ Shilling

Russ Shilling

  • 8 Posts
  • 0 Likes
I have a similar problem. Running FF3, with Flash ver. 9. SoundManager complains about version 8:

soundManager._initMovie(): Got EMBED element (created via JS)
soundManager._initMovie(): Waiting for ExternalInterface call from Flash..
soundManager.beginDelayedInit(): Document loaded
soundManager: Getting impatient, still waiting for Flash.. ;)
soundManager: No Flash response within reasonable time after document load. Possible causes: Flash version under 8, no support, or Flash security denying JS-Flash communication.
soundManager: Failed to initialise.
soundManager.disable(): Disabling all functions - future calls will return false.
-- SoundManager 2 failed to load (security/load error) --
soundManager.initComplete(): calling soundManager.onerror()
Photo of Scott

Scott, Official Rep

  • 3780 Posts
  • 241 Likes
Hey Russ, what version of SM2 is that specifically? Got a live example/demo URL where the problem can be reproduced? Sounds odd that Flash 9 works, but not Flash 8.
Photo of Russ Shilling

Russ Shilling

  • 8 Posts
  • 0 Likes
I downloaded the latest version, 2.77a. And I don't think Flash 9 works, either. It's odd, some browsers work okay, others don't. (IE is particularly bad, of course!) http://aragon-online.net is the URL. There is no sound on a basic page load, but I *think* SoundManager is what is causing the problem. Either that, or something in my javascript code.
Photo of Russ Shilling

Russ Shilling

  • 8 Posts
  • 0 Likes
I've made progress. Now I've broken SoundManager in ALL browsers (LOL!) Every browser causes the error alert box instead of loading SM2. I'm wondering if this code is the problem:

<script type='text/javascript'>
soundManager.debugMode = true; // disable debug output
soundManager.url = './include/soundmanager2.swf'; // path to movie
soundManager.waitForWindowLoad = true;
soundManager.onload = function() {
animation_stack = [''];
begin_animations();
}
soundManager.onerror = function() {
alert('SoundManager error');
}
function begin_page () {
init_map(1);
}
</script>

I've checked everything I know to check, such as the path to the swf file. The begin_page function is called in window.onload event.
Photo of Russ Shilling

Russ Shilling

  • 8 Posts
  • 0 Likes
I reloaded version 20b, and it suggested that security is the problem, which seems correct. What do I add to Flash to allow it to access the files on localhost correctly?
Photo of Russ Shilling

Russ Shilling

  • 8 Posts
  • 0 Likes
I found the solution, but have no idea why this problem suddenly developed. I removed the URL setting (below), and moved the soundmanager2.swf to the folder where all the pages live. Now, the current version is working fine in FF, Chrome and IE. I'd be curious to know why, suddenly, this began to fail?

soundManager.url = './include/soundmanager2.swf'; // path to movie
Photo of Russ Shilling

Russ Shilling

  • 8 Posts
  • 0 Likes
Here's the reason: the url property doesn't use the filename in this version, only the path. It still doesn't work if I put the swf file in the include folder, but I can live with that!
Photo of Scott

Scott, Official Rep

  • 3780 Posts
  • 241 Likes
I recommend using an "absolute" path, but not including the fully-qualified domain name (eg. I don't recommend using a full URL like http://example.com/path/to/whatever/ , but instead something like /path/to/swf/ ) - then this will work regardless of what path you might be viewing on your web server.

eg. soundManager.url = '/path/to/soundmanager2/swf/directory/';

Keep in mind that the URL format did change with a recent version update - older versions do require the soundmanager2.swf in the URL, where newer ones only need the directory path.

If you want, you can use the old URL path, eg:

soundManager.url = '/path/to/soundmanager2/soundmanager2.swf';

And newer versions of SM2 will simply ignore the file name part of the URL.

If you view your content offline and want to switch URLs depending on whether or not you're loading over HTTP for example, you can look at loading SoundManager 2 offline and online. For example, say if you wanted the URL to be c:\documents and settings\user\desktop or file://something when loading from your computer's local file system offline, and then /path/to/something when loading over HTTP.

I'll look at adding an offline URL parameter for SM2 in a future version, also, to make it easier for people.
Photo of Scott Carver

Scott Carver

  • 1 Post
  • 0 Likes
Just spent too long debugging this same error. Turns out everything was fine aside from a missing closing bracket in the initialization code. If you are getting this error and have tried everything else perhaps copy and paste the template from the demo. I suppose that it was causing a flash init error, but not in the way I imagined (server permissions, bad path). Perhaps a future update to the debugger will include a more specific breakdown of the flash init error. No complaints though, SM2 is awesome and I'm happy to be using it.
Photo of Scott

Scott, Official Rep

  • 3780 Posts
  • 241 Likes
Odd, sounds like a JS error was breaking things? It's a little funny because of the way JS + Flash start up, sometimes if there is a JS error within the scope of soundManager.onload() the error won't "fall through" all the way to the console, and things will silently fail. I'm not sure if there is a nice way around this, unfortunately.

Glad SM2 is of use to you!
Photo of danD

dan

  • 7 Posts
  • 1 Like
I have a similar problem. The thing is this works on my development server, but does not work on my remote server. So, I think it may have something to do with the time it takes to download the mp3 file from the remote server.

On the development (local) server, where it works, the debugging output looks like this:

SMSound.play(): "mySound"
SMSound._onload(): "mySound" loaded.
soundManager.load(): sounds/chinesesounds-mp3/n/1884.mp3
SMSound.play(): Attempting to load "mySound"
SMSound() merged options: { id: mySound, url: sounds/chinesesounds-mp3/n/1884.mp3, autoLoad: false, stream: true, autoPlay: false, onbeforefinishtime: 5000, onjustbeforefinishtime: 200, multiShot: true, multiShotEvents: false, pan: 0, volume: 100 }
soundManager.createSound(): mySound (sounds/chinesesounds-mp3/n/1884.mp3)

from the remote server (running on this same local computer), the output looks like this:

SMSound.load(): Exception: JS-Flash communication failed, or JS error.
soundManager.load(): sounds/chinesesounds-mp3/n/1743.mp3
SMSound.play(): Attempting to load "mySound"
SMSound() merged options: { id: mySound, url: sounds/chinesesounds-mp3/n/1743.mp3, autoLoad: false, stream: true, autoPlay: false, onbeforefinishtime: 5000, onjustbeforefinishtime: 200, multiShot: true, multiShotEvents: false, pan: 0, volume: 100 }
soundManager.createSound(): mySound (sounds/chinesesounds-mp3/n/1743.mp3)
Photo of Scott

Scott, Official Rep

  • 3780 Posts
  • 241 Likes
My guess is SM2 is having problems starting up on your remote server, for whatever reason; make sure it is not complaining about security errors when soundManager.onload() / onerror() fire initially - that's likely what's going on - and if so, check the debug output for suggested fixes. When served over HTTP, the SWF should be served from the same domain and port as the hosting page etc., or the Flash portion of SM2 will fail.
Photo of danD

dan

  • 7 Posts
  • 1 Like
stupid stupid stupid... i didn't have flashblock disabled for that site...

great program, by the way. you have no idea how many hours and hours and hours i spent trying to get sound for my online application before i found soundmanager2... when will this be a pay-for product?
Photo of Scott

Scott, Official Rep

  • 3780 Posts
  • 241 Likes
Glad to help. I think when software works well and is free, the latter attribute is just one more reason to use it. ;) Audio control has been missing for a long time from browsers, so this project exists to help bridge the gap.
Photo of Russ Shilling

Russ Shilling

  • 8 Posts
  • 0 Likes
Add a PayPal Donate button, and I'll contribute.
Photo of Scott

Scott, Official Rep

  • 3780 Posts
  • 241 Likes
I appreciate your generosity! SM2 is powered strictly by goodwill, nice comments and emails from folks like yourselves. :)
Photo of rob giardinaRG

rob giardina

  • 1 Post
  • 0 Likes
it could also be if #sm2-container is set to display:none, which i did :/

in that case, flash won't load.
Photo of Scott

Scott, Official Rep

  • 3780 Posts
  • 241 Likes
Yep, good call; Flash will not load if the object/embed (or its parent container(s)) are display:none.
Photo of Nathan

Nathan

  • 11 Posts
  • 1 Like
I'm having an issue with Firefox and SoundManager2. When I click the play button, instead of starting the song, it goes directly to the MP3 file link. But this only happens when on the actual web server; when it's on my computer (localhost) it works fine.

The web console is like this online on the actual server (where it's not working):



On localhost, it works fine:



In Chrome, it works completely fine online and on localhost.

Any ideas why it works fine in Chrome for both, but in Firefox it only works on localhost?

Thanks,
Nathan
Photo of Scott

Scott, Official Rep

  • 3780 Posts
  • 241 Likes
Looks like SM2 isn't loading or can't find the SWF when loading over HTTP, and so it can't start and thus links to MP3s fall through to the browser. I'd check the path for the soundManager url on your server, and make sure the URL is valid.
Photo of Nathan

Nathan

  • 11 Posts
  • 1 Like
Yeah, it was a path issue. It's fixed now. Thanks for the reply.
Photo of Scott

Scott, Official Rep

  • 3780 Posts
  • 241 Likes
Good stuff. :)