Fatal Error

  • Problem
  • Updated 4 years ago
  • Solved
I have the latest version of shareholic on my blog but have to disable it.

When i activate the plug in my site crashes and i get this error:

Warning: require_once(./includes/class_bootstrap.php) [function.require-once]: failed to open stream: No such file or directory in /nfs/c09/h01/mnt/127936/domains/www.bootcamp4me.com/html/global.php on line 15

Fatal error: require_once() [function.require]: Failed opening required './includes/class_bootstrap.php' (include_path='.:/usr/local/php-5.2.17/share/pear') in /nfs/c09/h01/mnt/127936/domains/www.bootcamp4me.com/html/global.php on line 15

I do have wp minify on the site as well as w3 total cache..... please inform me how to get all these guys to work nicely together

Thanks
Photo of Lonnie Fluty

Lonnie Fluty

  • 7 Posts
  • 0 Reply Likes
  • confused

Posted 4 years ago

  • 2
Photo of Shareaholic HelpdeskSH

Shareaholic Helpdesk

  • 469 Posts
  • 7 Reply Likes
Lonnie,

What's your Blog URL? Is this the one - http://www.bootcamp4me.com/blog/ ?

If yes, you don't have SexyBookmarks installed on it, do you?

Please let us know and we'll be glad to help!
Photo of Lonnie Fluty

Lonnie Fluty

  • 7 Posts
  • 0 Reply Likes
The blog is something I was thinking of using but have not got around too yet.

As of right now your plugin is installed but not activated due to it crashing the site.

I used to have the shareholic at the bottom of all the pages on the site, but then i deactivated it over concerns of it slowing down the site and lowering the yslow and pagespeed scores.

I have since tweeked the site so the increased load the shareholic would put on site speed would be minimized... however, not it crashes the site with the above mentioned fatal errors.
Photo of Lonnie Fluty

Lonnie Fluty

  • 7 Posts
  • 0 Reply Likes
I tried to delete the plug in and do a fresh download and install... after clearing cache and minified settings i get this error

again.. the site turns white and i just get this text

Warning: require_once(./includes/class_bootstrap.php) [function.require-once]: failed to open stream: No such file or directory in /nfs/c09/h01/mnt/127936/domains/www.bootcamp4me.com/html/global.php on line 15

Fatal error: require_once() [function.require]: Failed opening required './includes/class_bootstrap.php' (include_path='.:/usr/local/php-5.2.17/share/pear') in /nfs/c09/h01/mnt/127936/domains/www.bootcamp4me.com/html/global.php on line 15
Photo of Lonnie Fluty

Lonnie Fluty

  • 7 Posts
  • 0 Reply Likes
17 days later... still no help.....

any ideas?
Photo of Shareaholic HelpdeskSH

Shareaholic Helpdesk

  • 469 Posts
  • 7 Reply Likes
@Lonnie - I've passed on the issue to our S/W Development Engineer and we'll be getting back to you. Sorry for the delay, since you didn't have SexyBookmarks installed on your blog, it was difficult for us to detect.
Photo of Lonnie Fluty

Lonnie Fluty

  • 7 Posts
  • 0 Reply Likes
I cant leave it installed because the site will not work with it installed.

I tried to deactivate all plugins and run it again and got this again

Warning: require_once(./includes/class_bootstrap.php) [function.require-once]: failed to open stream: No such file or directory in /nfs/c09/h01/mnt/127936/domains/www.bootcamp4me.com/html/global.php on line 15

Fatal error: require_once() [function.require]: Failed opening required './includes/class_bootstrap.php' (include_path='.:/usr/local/php-5.2.17/share/pear') in /nfs/c09/h01/mnt/127936/domains/www.bootcamp4me.com/html/global.php on line 15
Photo of Lonnie Fluty

Lonnie Fluty

  • 7 Posts
  • 0 Reply Likes
Another update.

I turned off all plugins, reset the cache...

downloaded the latest shareaholic and activated it... got the same fatal error.

The theme is striking
Photo of Shareaholic HelpdeskSH

Shareaholic Helpdesk

  • 469 Posts
  • 7 Reply Likes
O.K. - we're still at it. I've forwarded your issue to our S/W dev. team.
Photo of Ankur

Ankur, Software Engineer

  • 177 Posts
  • 10 Reply Likes
@Lonnie Fluty,

What the root directory path of the wordpress install ?

The files(/includes/class_bootstrap.php , global.php ) you mentioned does even lie inside the wordpress install directory directory ?

Please check and let us know.

Thanks,
Ankur
Photo of Lonnie Fluty

Lonnie Fluty

  • 7 Posts
  • 0 Reply Likes
I fixed it myself.. thanks
Photo of Shareaholic HelpdeskSH

Shareaholic Helpdesk

  • 469 Posts
  • 7 Reply Likes
Good to know, Lonnie!