Unable to turn off SexyBookmarks on post by post basis

  • Problem
  • Updated 1 year ago
  • Solved
The SexyBookmarks plugin is installed and working on our install of WordPress. However, on some posts we do not have the checkbox available to turn it off. Also, when attempting to enter in a custom field in WordPress using the name of "Hide SexyBookmarks" and the value of "True" it still displays. Any help is appreciated.
Photo of Mark G

Mark G

  • 9 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Celeste

Celeste, Official Rep

  • 899 Posts
  • 16 Reply Likes
Mark,

Could you please direct me to your blog? Thank you.
Photo of Mark G

Mark G

  • 9 Posts
  • 0 Reply Likes
Hello C Reign,

Sorry I was not able to reply to this sooner.

Also, unfortunately I can't link to the blog as we are doing testing on our own in-house server before we publish it to the web. Could this possibly be linked to the problem I am currently having?
Photo of Mark G

Mark G

  • 9 Posts
  • 0 Reply Likes
I managed to create a fix for this. I had to add an empty php tag to the page I didn't want to have the plugin popup on, and instead of True, type in 1 for the custom field of "Hide SexyBookmarks"
Photo of Jorge Salazar Morantes

Jorge Salazar Morantes

  • 2 Posts
  • 0 Reply Likes
Mark G. ... I do not know PHP, could you please share how should I write that php tag in oder to hide SexyBookmarks?
Photo of Celeste

Celeste, Official Rep

  • 899 Posts
  • 16 Reply Likes
Mark,

The fact that the blog isn't live shouldn't affect your ability to turn off posts. Are these custom posts or standard? Is the ability to toggle bookmarks on/off missing on certain posts and visible on others?

http://support.shareaholic.com/custom...
Photo of Mark G

Mark G

  • 9 Posts
  • 0 Reply Likes
The posts in particular we wanted to move them off of were custom posts designed for telling a little about the major people in the company. On these posts, the checkbox that is available for other posts to hide the plugin is not available. However, the custom field options are still available and originally using the option of setting Hide to True did not work for some reason. Does this plugin have some functionality problems with custom posts as opposed to normal blog style posts?
Photo of Celeste

Celeste, Official Rep

  • 899 Posts
  • 16 Reply Likes
Mark,

I'm discussing the issue with our technical team to see if there is a solution that can be offered. Your patience in the meantime is greatly appreciated.
Photo of Celeste

Celeste, Official Rep

  • 899 Posts
  • 16 Reply Likes
Mark,

We currently do not support custom post types. I didn't want to give you this information without verifying. If you have found a clever trick to disable on custom post types, I applaud your ingenuity. Although we do not currently support custom post types, we may in the future.
Photo of Mark G

Mark G

  • 9 Posts
  • 0 Reply Likes
Thank you very much for the information. I will keep that in mind moving forward with what page types we use for this site.
Photo of Patrick Houston

Patrick Houston

  • 1 Post
  • 0 Reply Likes
Mark G's solution to turn off bookmarks on individual pages also works for hiding Recommendations on a per page basis.
Photo of Jorge Salazar Morantes

Jorge Salazar Morantes

  • 2 Posts
  • 0 Reply Likes
Anybody can tell me how to add an empty php tag in order to hide SexyBookmarks in a landing page created with inbound now plugin? This is due to the "Hide SexyBoomarks options" do not appear in the page options and neither the custom fields options.
Photo of William Huff Jr.

William Huff Jr.

  • 1 Post
  • 0 Reply Likes
Did anyone get this solved? Running into the same problem with custom post types.

Thanks.

WH
Photo of mikocoffey

mikocoffey

  • 1 Post
  • 0 Reply Likes
@ William:

Yes, I did manage to get this working. I had to add a Custom Field to the post. Follow the instructions here: http://wordpress.org/support/topic/di...

BUT (IMPORTANT!!):
Instead of Value = "True" put the number "1" in the value box.

See screenshot: