Wrong URL is being called in TopBar

  • Problem
  • Updated 3 years ago
  • In Progress
In this article: http://www.danielodio.com/2012/04/12/...

there are a few problems with the TopBar:

1) The wrong URL is being called. You can see that the TopBar is referencing the post "Efficiency Hack: Hybrid hard drive" in this screenshot: http://drod.io/411A2Y1e1H2Z2m3I1U2j. That's an old article, not the current one for that page.

2) The Facebook button isn't showing.

Here's what my implementation looks like: http://drod.io/053k3O250F1a3z2M2H1P
Photo of DROdio

DROdio

  • 6 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Celeste

Celeste, Official Rep

  • 899 Posts
  • 16 Reply Likes
I see that you are running version 4.0.6.4. Could you please update to version 4.0.6.10 - http://bit.ly/yi91y0 - to check if that corrects the problem?

When I view your page, the Facebook buttons are visible in the TopBar. Are they now visible on your end?

If you have any caching plugins active, clear those before refreshing your page, then retry the TopBar share.
Photo of DROdio

DROdio

  • 6 Posts
  • 0 Reply Likes
Thx for the help:

I updated to the latest version; top bar is still not working correctly.

Yes, the buttons ARE visible, but they reference the wrong blog post.

For example, this one: http://www.danielodio.com/2012/04/13/... is not about Canadian Music Week... however when I click "tweet" that's what I get:

Photo of Celeste

Celeste, Official Rep

  • 899 Posts
  • 16 Reply Likes
I'm escalating this case to our technical team for review, and will keep you posted on any updates. Please, leave the TopBar active during this time, because they'll likely be scanning your code. Your patience is greatly appreciated. Thank you.
Photo of DROdio

DROdio

  • 6 Posts
  • 0 Reply Likes
Thanks Celeste
Photo of DROdio

DROdio

  • 6 Posts
  • 0 Reply Likes
Celeste, what's the word on this? It's been 13 days since you escalated it and 20 days since I reported this bug. It's still happening. For example, here's a post I just wrote yesterday: http://www.danielodio.com/2012/05/01/...

But Shareaholic thinks the post is about Turner Broadcasting -- it's not.

Photo of Celeste

Celeste, Official Rep

  • 899 Posts
  • 16 Reply Likes
I've revisited the escalation to request an update. They will be notified via email. As soon as I receive word, you'll be contact immediately.
Photo of Celeste

Celeste, Official Rep

  • 899 Posts
  • 16 Reply Likes
In the meantime, there are two things I'd like for you to try. Maybe we can figure out the problem on our own.

#1. Momentarily change your theme to Twenty Eleven and check if the issue is still present.

#2. Deactivate all of your plugins (other than Shareaholic), check the TopBar behavior again.

Do either of these suggestions correct the problem?
Photo of Celeste

Celeste, Official Rep

  • 899 Posts
  • 16 Reply Likes
Update: If the above didn't help, try removing the Classic Bookmarks widget momentarily. We haven't performed compatibility testing to see if there is a conflict when pairing our plugin alongside one of our widgets. It is possible that the problem rests here. Please, let me know if any of these things work for you.