How do I disable "On-Hover"?

  • Question
  • Updated 1 year ago
  • Answered
Hi, Does anyone know how to get a customized Share This button 'on click' rather than 'on mouse hover'
Thanks
Photo of steversb

steversb, Official Rep

  • 368 Posts
  • 32 Reply Likes
  • Perplexed

Posted 6 years ago

  • 98
Photo of steversb

steversb, Official Rep

  • 368 Posts
  • 32 Reply Likes
To disable the widget from opening on hover, you can add "onmouseover=false" to your ShareThis widget code. For example:


<script type="text/javascript"
src="http://w.sharethis.com/button
/sharethis.js#publisher=123456-7890a-bcdefg-hijkl&type=website&
onmouseover=false"></script>
Photo of Sarugu - Tech Blog

Sarugu - Tech Blog

  • 4 Posts
  • 0 Reply Likes
In new template I could not find any code like this... This is possibley old support message.

Anybody knows how to disable mouse over in New Sharethis Code.
Photo of steversb

steversb, Official Rep

  • 368 Posts
  • 32 Reply Likes
Hi,

Just tested and confirmed, this code still works.
Photo of Sarugu - Tech Blog

Sarugu - Tech Blog

  • 4 Posts
  • 0 Reply Likes
Hi, Thanks for your reply.

But please tell me how to add this trick in the following sharethis widget code...?

-----------------

-----------------

Now this code is present in my blog. http://sarugu.com.

Waiting for your reply to change the mouse over option.
Photo of Sarugu - Tech Blog

Sarugu - Tech Blog

  • 4 Posts
  • 0 Reply Likes
Hi steversb, I could not see any code here. Possible Getsatisfaction disabling the option.

Can you please upload it in rapidshare? and share the link here...
Photo of steversb

steversb, Official Rep

  • 368 Posts
  • 32 Reply Likes
Here is a link to the code that you will need:

http://blog.sharethis.com/example-cod...
Photo of Sarugu - Tech Blog

Sarugu - Tech Blog

  • 4 Posts
  • 0 Reply Likes
Hi steversb,

Thanks for your wonderful support. Appreciated... :)
Photo of Not ProvidedNP

Not Provided

  • 4 Posts
  • 1 Reply Like
Having your ShareThis pop-ups constantly appear on my browser is like having cockroaches run across my food. You need an easy way to turn this off, or disable it forever. Unless I /we ask for it. You need to understand the disgust we feel for ShareThis' infestation of our computers, and the constant interruptions in our work. Please help, most of us do not write code into our registries, we just want you gone.
Thanks in advance.
Photo of Dmitri Farkov

Dmitri Farkov

  • 1 Post
  • 0 Reply Likes
Hahaha, that's hilarious. I hope you don't work at a web dev company
Photo of gregnasonG

gregnason

  • 2 Posts
  • 0 Reply Likes
My sentiments exactly, phrased as well as possible
Photo of steversb

steversb, Official Rep

  • 368 Posts
  • 32 Reply Likes
Hi,

Our button only pops up it's iframe if you hover your mouse over it. This is an option that can be disabled by the publisher. If you are bothered by this on a specific site you can contact the sites administrator and request that they disable this function.
Photo of MisterMidnightM

MisterMidnight

  • 1 Post
  • 0 Reply Likes
"Our button only pops up it's iframe if you hover your mouse over it."

Uhh, that's the problem!! WHY in the world is the box designed this way? If the goal was to annoy people than you have succeeded 100%. I am bothered by this annoyance on ALL sites that have it, HOW do I disable it for ALL sites so that I don't keep accidentally opening it all the time?
Photo of steversb

steversb, Official Rep

  • 368 Posts
  • 32 Reply Likes
Hi,

Disabling OnHover is a setting that must be set by the publisher. It's not controllable on the user end.
Photo of Tony Schafer

Tony Schafer

  • 1 Post
  • 0 Reply Likes
I am looking to disable the sharethis box that pops up when I go to sharethis for Facebook, Yahoo etc. I think the layout of this popup looks horrible but I love sharethis and the way my button worked on my other sites. I dont know where to change this . Please help
Photo of steversb

steversb, Official Rep

  • 368 Posts
  • 32 Reply Likes
Hi,

I'm not quite sure what you mean. With the current ShareThis buttons, clicking on facebook should send you straight to facebook.

Are you using the new beta version of the widget?
Photo of Not ProvidedNP

Not Provided

  • 4 Posts
  • 1 Reply Like
Steve, you seem not to get that you have users who are sufficiently frustrated and/or angry that they are contacting you because they want a solution. When people stay your feature is as much fun as having cockroaches running across their food, it is because the want to get rid of the cockroaches appearing on their own computers.. When you say: "Disabling OnHover is a setting that must be set by the publisher. It's not controllable on the user end." or tell them to "contact the publisher", you are not being helpful. People are asking how to keep the cockroaches off their system, and you are saying this must be addressed on a site-by-site basis. When the web providers do not self-regulate, regulation needs to be imposed. You would be better saying "Write your congress-person, and suggest that they direct the FCC to establish standards and practices to prevent malicious and inappropriate code that hijacks peoples' computers". When the web does not self-regulate, regulation must be imposed to get rid of the cockroaches. Personally, I think it would be better to provide the user with a disable button, but the alternative for those who are disturbed by this is to write your representatives and ask them to provide congressional authority for the FCC to clamp down on these kinds of inappropriate features that hijack control of their computer systems to display unwanted content. At least that way, you get to do something instead of feeling like a victim.
Photo of gregnasonG

gregnason

  • 2 Posts
  • 0 Reply Likes
if I could like this reply I would. Good answer.
Photo of mgregg99M

mgregg99

  • 6 Posts
  • 0 Reply Likes
I've recently installed this plugin on my Wordpress blog and I'd like to remove the on-hover feature as well. Please let me know what I can do to remove it.

I've tried using the code provided above, but it didn't help.

Thanks!

Mike
www.itsmygallery.com
Photo of steversb

steversb, Official Rep

  • 368 Posts
  • 32 Reply Likes
Hi,

The code listed above is for the old widget style.

Here are the instructions for our current code:

http://help.sharethis.com/customizati...
Photo of mgregg99M

mgregg99

  • 6 Posts
  • 0 Reply Likes
Okay, I'm not very bright. I've looked in the sharethis.php file and tried to find where I could add the onhover: false; command, but I'm not getting anything other than syntax errors when trying to test it.

Please let me know where and how to add the command in the sharethis.php file so I can get this working.

Thanks!

Mike
www.itsmygallery.com
Photo of steversb

steversb, Official Rep

  • 368 Posts
  • 32 Reply Likes
Hi,

You should be able to edit it on the settings page of the ShareThis plugin. No need to edit the php file.

#5 here is the box you would want to make the changes in:

http://help.sharethis.com/integration...
Photo of mgregg99M

mgregg99

  • 6 Posts
  • 0 Reply Likes
Okay, thanks. I think I have it working the way I want now.

Mike
www.itsmygallery.com
Photo of Pete Bella

Pete Bella

  • 1 Post
  • 0 Reply Likes
steversb, I'm also trying to accomplish the disable on hover. Following the directions, but no success. in options #5 pasting the code:



<span class="st_sharethis_button" displayText="Share"></span>

<script type="text/javascript" src="http://w.sharethis.com/button/buttons.js"></script>
<script type="text/javascript">
stLight.options({
publisher: '12345',
onhover: false
});
</script>


into my existing code:



<span class='st_sharethis_large' st_title='<?php the_title(); ?>' st_url='<?php the_permalink(); ?>' displayText='sharethis'></span>
<span class='st_facebook_large' st_title='<?php the_title(); ?>' st_url='<?php the_permalink(); ?>' displayText='facebook'></span>
<span class='st_twitter_large' st_title='<?php the_title(); ?>' st_url='<?php the_permalink(); ?>' displayText='twitter'></span>
<span class='st_pinterest_large' st_title='<?php the_title(); ?>' st_url='<?php the_permalink(); ?>' displayText='pinterest'></span>
<span class='st_email_large' st_title='<?php the_title(); ?>' st_url='<?php the_permalink(); ?>' displayText='email'></span>
<span class='st_plusone_large' st_title='<?php the_title(); ?>' st_url='<?php the_permalink(); ?>' displayText='plusone'></span>


again, no success... I've put everything back to the stock/defaults for now. Here is the url to my site where I've tried to use this feature: http://peterbella.com/index.php/categ...
Photo of Herman Milous

Herman Milous

  • 1 Post
  • 0 Reply Likes
"Disabling On Hover is a setting that must be set by the publisher. It's not controllable on the user end." - Steversb

Uhh, how about you design the program to NOT have the hover as the default???? Or are the programmers not smart enough to figure this out?

Let me get this straight - I am supposed to contact each and every web site that uses your stupid pop-up? Are you kidding me?? Sheesh. Moronic programming at its finest.

Companies with such irritating ads RUIN the internet. How sad that there are such inconsiderate people who design this crap. A day doesn't go by that I don't have to click that stupid box closed 5-10 times. #@#! the folks who designed this and decided to make it so annoying.
Photo of Tiara Jedy

Tiara Jedy

  • 1 Post
  • 0 Reply Likes
afeel\
i feel we should go on cause if one is not a criminal thenh why should u fear sharing a page so fo me isay sharing is not bad and dis practice should be adopted by many other congrigation
Photo of Alfia Brown

Alfia Brown

  • 2 Posts
  • 0 Reply Likes
Thanks ,only wanted to know if I did, or ever did want to resign.
Photo of Julian Coates

Julian Coates

  • 1 Post
  • 0 Reply Likes
1 year since the last post, 4 years apparently since this thread started, still the same problem! I have a Wordpress site with sharethis plugin, I put onhover:false exactly as instructed and it has no effect. Also, every time I return to step six of the plugin set up process, my previous edits to the code are replaced with the default code. I expect, as always, I will be told to disable all other plugins and see if it is still a problem, which, as always, is an immense pain to do.