Changing the brush opacity

  • Problem
  • Updated 2 years ago
In Sketchbook 5.2 on OS X 10.6 w/ an Intuos 4, how do you change the brush opacity? I've been trying to tap the brush, then holding the O-key. I then see a box saying "Opacity: 1.0," but the value never changes when I move my stylus (like with the brush size).
Photo of edavepitman

edavepitman

  • 1 Post
  • 0 Reply Likes

Posted 4 years ago

  • 10
Photo of adsk.mat

adsk.mat, Employee

  • 172 Posts
  • 16 Reply Likes
Hi,

At the moment this functionality only works for brushes which have opacity settings in the Ui (Opacity for heavy and low pen pressure).

So it will work with the preset brushes or do-it-yourself brushes, but not with e.g. a pencil or an airbrush (which has a flow).
Photo of ugoharris

ugoharris

  • 3 Posts
  • 0 Reply Likes
I tried with the regular brushes but it wouldn't work for me. I'm using a mac.
Photo of ayalacortes

ayalacortes

  • 2 Posts
  • 1 Reply Like
In my macbook pro I'm using a normal mouse and pressing the "O" key + dragging doesn't change Opacity value. The box showing "Opacity 1.00" appears but nothing changes no matter how much you click/drag.

This will be a very handy tool to use with a mouse or trackpad but.... perhaps this is a stylus / tablet only feature (?)

In the SketchBook Mobile you can change size and opacity in the same 'puck'. In SketchBook Express the 'puck' only changes the brush size.
Photo of ugoharris

ugoharris

  • 3 Posts
  • 0 Reply Likes
Thanks for your reply

I guess this is a problem that the makers of that software will have to fix.
Photo of ayalacortes

ayalacortes

  • 2 Posts
  • 1 Reply Like
update on my post above...

Apparently opacity change with the O -key only works on some custom brushes or in some of the presets available in the Pro version. Since Sketchbook Express does NOT have these brush sets it seems that the opacity feature is just there for decoration and is completely useless. Still the feature appears in the users manual for the Express version. Probably someone forgot to remove the "feature" from the manual.

The question is now... Does this Opacity feature works in the Pro version when using a mouse...or does it work only with a stylus? worth to know before buying the Pro version I guess. Otherwise you have to deal with an extra "tool options floating window" all the time... and move around with you laptop, tablet and stylus to use the O-key function.
Photo of adsk.mat

adsk.mat, Employee

  • 172 Posts
  • 16 Reply Likes
Hi,

Thank you for pointing the discrepancy between the docs and the Express functionality. We will review it.

In Express, you can change the opacity of applicable brushes, but you indeed need to use the Brush properties window.

Regarding Pro, The O-key does work with mouse, a stylus, and the track-pad.

Thank you
Photo of richb.moore

richb.moore

  • 1 Post
  • 0 Reply Likes
I am not sure why pressing the "o" key is now necessary. I use a modbook (no keyboard, just stylus) and also a cintiq 22". The beauty of Sketchbook Pro was not having to press any keys. This is a step in the wrong direction.
Photo of Jani Partanen

Jani Partanen

  • 1 Post
  • 0 Reply Likes
I agree with rich.moore. In Sketchbook Pro for iPad the opacity works nicely from brush preset ring and it should work the same way in osx (IMHO).
Photo of ugoharris

ugoharris

  • 3 Posts
  • 0 Reply Likes
Thanks for your replies guys. Guess, I just have to upgrade to the Sketchbook Pro.
Photo of Brandon Hatcher

Brandon Hatcher

  • 1 Post
  • 0 Reply Likes
I just downloaded sketchbook pro 2011 v5.2 and I can not get the opacity to work from the brush lagoon. I tried with all types of brushes. My problem is the same as the above. The opacity 1.0 box shows up but does not change.

It seems like this is a bug.
Photo of Jon Antoni

Jon Antoni

  • 3 Posts
  • 0 Reply Likes
I'm having the same problem, has anyone figured this out yet?, Is this a Mac specific problem?
Photo of chucks2

chucks2

  • 1 Post
  • 0 Reply Likes
Absolutely agree. I have Sketchbook Pro and with 5.1 you could adjust the opacity in the brush properties ring. With 5.2 you can no longer adjust the opacity unless you hold down "O". Sketchbook Pro was the perfect no keyboard solution. I don't want to have to touch my keyboard. AUTODESK BRING BACK OPACITY IN THE BRUSH PROPERTIES RING!!!!!!!!!!!!!!! MAJOR OVER SIGHT!!!
Photo of Ross Moyer

Ross Moyer

  • 1 Post
  • 0 Reply Likes
Yeah, not really sure what the problem is here. I'm using this for Windows. The Employee says that in Sketchbook Pro the O-key works, yet I have Sketchbook Pro and when I select the Paint Brush and then hold down 'O' and stroke with my stylus, the Opacity does not change at all.

Something is wrong with the interface. The Tilt hotkey works just fine for the brushes that have the tilt property. The Opacity hotkey does not work.

PS

Ok, so as another poster pointed out, the O-Key does work if I make a Do It Yourself copy of the Paint Brush...for some reason....I don't know why it isn't recognized with the original Paint Brush though...
Photo of eyelyn

eyelyn

  • 1 Post
  • 0 Reply Likes
Me, same problem. I have Sketchbook Pro (5.2) for the iPad and for my Mac (OS X 10.7). On the iPad the opacity feature works fine. On my Mac I'm working with a Cintiq 24 and it doesn't work. The opacity 1.0 box shows up but does not change.
I also agree with rich.moore and Jani Partanen. It should work in OS X like for the iPad: no key pressing, just sliding in the brush preset ring.
Photo of Leslie Ritchie-Dunham

Leslie Ritchie-Dunham

  • 1 Post
  • 0 Reply Likes
Same problem. I wish I hadn't upgraded to Pro as now I just feel frustrated having to deal with this! I can't even figure out how to change brush opacity at all - other than using layers -which bites. O key doesn't work. What does?? Help would be appreciated. Autodesk - FIX THIS PLEASE!!!
Photo of adsk.mat

adsk.mat, Employee

  • 172 Posts
  • 16 Reply Likes
Hi Leslie,

Double click on a brush icon to open its Brush Properties window. This window contains all the applicable attributes/sliders for that brush, like e.g. opacity.
Photo of Chris Knowles

Chris Knowles

  • 1 Post
  • 0 Reply Likes
I have Sketchbook Pro 5.5 for Mac. On the subject of opacity, does anyone have an issue with the brush setting 'opacity with light pen pressure' changing 0 to 1.00 which then means the brush is no longer responsive to light pen touches making light marks of 0.05 for example?

If I make a custom brush with a opacity with heavy pen pressure of 1.0 and a opacity with light pen pressure of 0.01 you get a brush that's pressure sensitive. If I then drop the opacity of the brush using 'o' to say 0.2 for some delicate blending, then move it back up to 1.0 as before my brush properties have change to opacity with heavy pen pressure of 1.0 and a opacity with light pen pressure of 0.75! So the brush no longer has much pressure sensitivity. I've tried with all brush as get the same result. This don't happen in any other painting software that I know, Photoshop Mac, Painter Mac, Artstudio for iPad. Only in Sketchbooks software on both Mac and iPad. On all these app the sensitivity remains the same what ever the opacity change up or down, which I use a lot when painting.

To te Employee 'Is this intentional?' If so why, if not how do you fix it?

To everyone else, do you find this to also be true? or have you found the answer in another forum question?

Thanks
Photo of Erf

Erf

  • 18 Posts
  • 2 Reply Likes
I've already complained about that opacity sensitivity problem, a few months ago. I received no response, so I'm guessing it's on purpose and there's no workaround. I wish they'd change this.
Photo of Friday2life

Friday2life

  • 1 Post
  • 0 Reply Likes
I had the same problem - opacity in OSX does not work with the puck, either with mouse or my Wacom pen and table.
However, the Autodesk reply from a month ago (Double click on a brush icon to open its Brush Properties window) does bring up an opacity slider. I agree the puck adjustment should work instead, as it does in IOS, and I hope that will be fixed soon.
Photo of macstertome

macstertome

  • 39 Posts
  • 6 Reply Likes
Same for me it doesn't work on my MBP and I have SKB Pro. I always used the slider but now that I have an intros it would have been handy to map that command to the tablet. Alas....just like incremental canvas rotation which was taken away from us.......
Photo of Eric Waldemar

Eric Waldemar

  • 3 Posts
  • 0 Reply Likes
Looking at how many months people have been complaining about basic issues with changing opacity, it seems like the desktop version of Sketchbook Pro is an extremely low priority for Autodesk. As was the case for others, I can get an opacity "indicator" by hitting "o", which I shouldn't need to do anyway, with this supposedly keyboard-free software. Like others, I'm unable to actually adjust the opacity, despite the pop-up box. Also, the installer that Autodesk makes available for download doesn't work on OSX Lion, which has been the current Mac OS for quite some time now. I was able to find and download a working version from their site after failing to get a useful response from their help desk. Surely someone could tell the help staff that the software doesn't work with the current Mac OS without downloading a separate version. They could have just sent me a link. Instead, a lot of time wasted searching Autodesk forums, trying to diagnose what turned out to be a known issue. I was excited about the current big discount on Sketchbook, but as it stands, it was no bargain, as it lacks basic opacity functionality after many years of development. Very disappointing. The age of similar posts in this thread suggests that a bug fix is unlikely any time soon. I'm a dissatisfied customer, but I don't think they really care, since I'm not purchasing a Maya seat. I'd been thinking of "moving up" to Maya from Cinema 4D, but I don't think I will now. Autodesk, your indifference has made an impression.
Photo of Akshay Pawar

Akshay Pawar

  • 5 Posts
  • 0 Reply Likes