An error occurred while importing the iTunes Library

  • Problem
  • Updated 5 years ago
Archived

This conversation was archived and is no longer visible to community members.

I am having difficulty importing my iTunes Music Library. Songbird says "An error occurred while importing the iTunes Library. Would you like to try importing again?"

I searched the Help topics, but none of the issues dealt with Mac OSX, so I thought I would post. I am running Mac OS 10.5.5 and just downloaded Songbird 1.0.

I love what I've seen so far of Songbird and would appreciate any help you can give me on this topic. Thanks!
Photo of

  • 3 Posts
  • 0 Likes
  • frustrated

Posted 6 years ago

  • 13
Photo of

  • 6 Posts
  • 0 Likes
Hey,

So I just got Songbird and ran into this same problem today. I fond the following:

http://bugzilla.songbirdnest.com/show...

But as far as I know this is not a solution... and the last post was a couple months ago... So let me know if you come across one!

Cheers
Photo of

  • 6 Posts
  • 0 Likes
Hey Tony,

So i have been working on it some more and it was suggested to me that I try 'reseting' Songbird (so my profile) to solve this issue. THEN, after reinsalling, select 'import itunes library' from the installation menu.

To Achieve this I had to 1) Remove it from the applications, 2) Open Terminal and enter the following commands:

rm -Rf ~/Library/Caches/Songbird2
rm -Rf ~/Library/Application\ Support/Songbird2
rm -f ~/Library/Preferences/org.songbirdnest.songbird.plist

NOW! This removed the profile and I was able to reinstall no problem BUT it still did NOT solve the problem.
Photo of

  • 2 Posts
  • 0 Likes
Same problem here with the latest osx, songbird and itunes as of today
Photo of

  • 6 Posts
  • 0 Likes
Hey all. There seems to be a string started on this issue already that has an employee on it. I have posted some screenshots of the issue.

http://getsatisfaction.com/songbird/t...
Photo of Hauke

Hauke

  • 26 Posts
  • 2 Likes
Are there any news on this topic? I still got the problem in version 1.1.1. You guys too?
Build 1018 (20090309144332) on Mac OS X 10.5.6
Photo of

  • 4 Posts
  • 0 Likes
I think its a problem with iTunes. When I try to import my iTunes library to an empty iTunes, on a different account on my computer, iTunes fails and gives me an error 500 or something like that. So it seems that when you got the problem you need to rebuild your iTunes library (you lose your playcounts), because its a corrupted library and alway a corrupted library.xml which can't be used in Songbird and iTunes as well.
What do you think?
Photo of

  • 4 Posts
  • 0 Likes
I can answer to my own question: I saved all my mp3 files to an external drive, deleted iTunes and all iTunes folder in user/music and Library and such. Then I reinstalled iTunes, imported all mp3 files and recreated my playlists. Afterwards I imported this new Library.xml to Songbird and it worked. So you can solve this problem when you rebuild your iTunes library. However you have to accept to lose you playcounts and ratings in iTunes. But these come back, someday... ;)
Photo of Hauke

Hauke

  • 26 Posts
  • 2 Likes
Thanks for that tip, Kalle. I didn't want to move all my files, I just deleted the Library files and re-installed iTunes and let iTunes search for music and build a new Library file. But sadly it didn't work. But I think it must have been the same procedure as yours as the Library has been rebuilt.
Photo of

  • 4 Posts
  • 0 Likes
Perhaps there is another reason for this problem.
But creating a new library worked for me the way I did it.
You can probably test if it works for you when you create a new account on your mac and try to import your library.xml to the empty itunes on the new account. If this won't work, try to rebuild your library like I did.
Photo of

  • 3 Posts
  • 0 Likes
A question to everyone who is having this problem: Which Mac are you using? I got this to work on my newer metal iMac, but not my older white plastic iMac. Could this be a clue to the problem?
Photo of

  • 2 Posts
  • 0 Likes
I am on a Mac pro 2x2.8Ghz Quad-Core Intel Xeon 2GB RAM OS X 10.5.6, latest itunes and songbird. ~60GB music library in itunes.
Photo of Hauke

Hauke

  • 26 Posts
  • 2 Likes
MacBook 2,16 GHz Core 2 Duo, 1 GM RAM, OSX 10.5.6, latest iTunes, latest Songbird, 50 GB music library
Photo of

  • 4 Posts
  • 0 Likes
Hey Tony, did you import your old iTunes library or have you created a new one...?
Photo of

  • 3 Posts
  • 0 Likes
I was doing the old one, so that my play counts and ratings would stay...haven't tried to do a new one
Photo of Hauke

Hauke

  • 26 Posts
  • 2 Likes
with the latest version of songbird (1.2 Mac) this problem disappeared
Photo of bijB

bij

  • 1 Post
  • 0 Likes
Hi!

I was running into the same problem.
I solved it by checking the iTunes library XML file with xmllint. Only one song had an invalid character as genre (located by xmllint). I removed that character in the xml file using a text editor (emacs) to get a valid xml file - another try was succesful!