Can't login Last.fm

  • Question
  • Updated 2 years ago
  • Answered
Hey guys!

So I can't seem to login into my Last.fm extension in songbird. This always worked for me until I updated songbird last night. For further explanations on the problem, please look at the picture provided.

What I've tried before:
- Yes, third party apps are checked.
- Yes, I re-installed the extension (more than once).
- Yes, I changed my password on Last.fm site to MAKE SURE I had the right password.

Can you figure out what's wrong?

Thanks for the help guys!
Photo of soullessonegamereplays

soullessonegamereplays

  • 13 Posts
  • 0 Reply Likes
  • frustrated

Posted 5 years ago

  • 67
Photo of LeMirque

LeMirque, Champion

  • 312 Posts
  • 27 Reply Likes
Just a shot in the dark, but did you try clearing cache and cookies in Songbird? (tools -> clear private data)
That solved it for me some time ago, if i remember correctly. Might be absolutely wrong idea though.
Photo of soullessonegamereplays

soullessonegamereplays

  • 13 Posts
  • 0 Reply Likes
I tried that before and it didn't work then. I just tried it now just to make sure, but still, no progress :-(

Thanks for the help though!
Photo of soullessonegamereplays

soullessonegamereplays

  • 13 Posts
  • 0 Reply Likes
Image didn't upload, here is the image I meant.
Photo of Bex

Bex

  • 7 Posts
  • 0 Reply Likes
Did you have accept third party cookies or an exception made for "*.last.fm"? See
http://getsatisfaction.com/songbird/t...
Photo of soullessonegamereplays

soullessonegamereplays

  • 13 Posts
  • 0 Reply Likes
Yes, I've read that topic before I created this thread and as I said in my original post, I have third party cookies enables AND have last.fm as a exception.
Photo of Bex

Bex

  • 7 Posts
  • 0 Reply Likes
Just trying to be helpful. Not to be too picky, but there was no mention of you doing either of the suggestions in your original post; nor any indication that the other thread had been reviewed.

I agree that the Last.fm plugin is a mess and it seems that there are numerous issues at play which exhibit themselves in a nearly identical way (which naturally is not very helpful to finding a diagnosis and is incredibly frustrating for everyone.)
Photo of Andy

Andy

  • 14 Posts
  • 3 Reply Likes
I have exactly the same problem after my update from SB version 1.4.3 to 1.7.2.
Photo of benbenben3

benbenben3

  • 9 Posts
  • 0 Reply Likes
Got the same problem here
Started Saturday June 5th
Tried new version of Last.FM application
Tried to run in safe mode
Tried new Songbird Profile
Tried changing proxies,
Tried 3rd Party application cookies enable

Very confused and frustrated
Anyone have an idea?

Can developers fix this one and make an update please?
Photo of Dragos Ristache

Dragos Ristache

  • 2 Posts
  • 0 Reply Likes
I have the same problem! It's getting really really annoying!!!
Tried everything ! Cmon, I need last.fm :(
Photo of Al.

Al.

  • 7 Posts
  • 0 Reply Likes
have the same problem too! what's wrong with it? damn!
Photo of Dmitry Fedorov

Dmitry Fedorov

  • 3 Posts
  • 0 Reply Likes
I have the same problem too, after updating from 1.4.3 to 1.7.2.
Photo of dbunder

dbunder

  • 2 Posts
  • 0 Reply Likes
Same deal. When I upgraded from 1.4.3, I completely deleted my songbird profile and started a brand new one. I've also uninstalled and reinstalled the last.fm addon several times, each time removing any remnants of it left behind in my profile.

Accepting cookies including third-party and have tried clearing all of my private data to no avail.

Totally crucial components broken... not good.
Photo of Dmitry Fedorov

Dmitry Fedorov

  • 3 Posts
  • 0 Reply Likes
I also tried everything? nothing helped) WTF, Songbird team?
Photo of Carlos

Carlos

  • 1 Post
  • 0 Reply Likes
Same problem, on a Windows 7 64bit machine
Photo of alfred

alfred

  • 459 Posts
  • 192 Reply Likes
The issue is tracked in bug 21359. There will be an update release for 1.7 to carry the fix for this problem. Please cc yourself to the bug list to get updates if you're interested.
Photo of Al.

Al.

  • 7 Posts
  • 0 Reply Likes
and what about old versions? they won't be fixed?!
Photo of alfred

alfred

  • 459 Posts
  • 192 Reply Likes
Old version could update the addon and get the fix as well.
Photo of soullessonegamereplays

soullessonegamereplays

  • 13 Posts
  • 0 Reply Likes
When should we be expecting this fix?

Not trying to be impatient, but if we got a time-window I wouldn't check this topic so frequently. :-)
Photo of Dmitry Fedorov

Dmitry Fedorov

  • 3 Posts
  • 0 Reply Likes
I need last.fm, men...
Photo of benbenben3

benbenben3

  • 9 Posts
  • 0 Reply Likes
tick tock
Photo of alfred

alfred

  • 459 Posts
  • 192 Reply Likes
The fix is in the tree already. It'll take a bit while to deploy/test the addon so that 1.7.2 users can just "Find Updates" on the addon preference page.

One alternative for now is to go with the trunk audio scrobbler addon. Please note that this addon is only compatible with Songbird trunk nightly (2.0.0a). To use it with 1.7.2, you'll have to go to the "about:config" page, add a config option "extensions.checkCompatibility" and set it to false. Then you'll be able to install the addon without checking the compatibility. Or you can just wait until the addon for 1.7.2 is ready.

Please also note that a grant permission tab will be opened in Songbird while logging in. You'll have to click the "Yes, allow access" button for the log in to complete.
Photo of benbenben3

benbenben3

  • 9 Posts
  • 0 Reply Likes
alfred, i did what u said and all I see is a grey last.fm box... can't login, cant even get a popup to appear.
Photo of alfred

alfred

  • 459 Posts
  • 192 Reply Likes
Oops, sorry. I only verified with my local 1.8 branch build, not the 1.7.2 one. Looks like the trunk build doesn't work with 1.7.2. You will have to wait for the addon is ready for 1.7.2 release.
Photo of benbenben3

benbenben3

  • 9 Posts
  • 0 Reply Likes
Thanks Alfred,
I will wait for the 1.7.2 release.
In the meantime, is there a way I can download and install the 1.8 stable Songbird, so it will work?
Is there a link somewhere?

Thanks!
Photo of alfred

alfred

  • 459 Posts
  • 192 Reply Likes
The 1.8 branch build is not available to the public. You'll have to wait for the beta to come out.

Another possible alternative needs a bit of hack.

1. Install the current broken last.fm addon to Songbird 1.7.2.
2. Remove the broken sbLastFm.js file from your audio scrobbler addon of the profile folder. The file should be in the subfolder extensions/audioscrobbler\@songbirdnest.com/components.
3. Download the sbLastFm.js file that's patched and save it to the same folder in step 2.

Then restart Songbird should give you the rescue.
Photo of RynGarcia

RynGarcia

  • 5 Posts
  • 0 Reply Likes
Thank you alfred :D The patch works perfectly. :D
Photo of Chad

Chad

  • 20 Posts
  • 0 Reply Likes
Odd. The patched file worked on SB 1.7.2 on Windows XP Professional SP3, but it failed to work on SB 1.7.2 on Windows 7 Home Premium 64-bit.

Any ideas why?
Photo of alfred

alfred

  • 459 Posts
  • 192 Reply Likes
I tried with 1.7.2 on my Windows 7 32bit box. It works fine. I wouldn't expect there could be any difference between 32bit and 64bit. It's mostly JavaScript code. Could you please try with a new profile to make sure that the profile isn't broken?
Photo of Louie

Louie

  • 2 Posts
  • 0 Reply Likes
That did the trick. Cheers.
Photo of Chad

Chad

  • 20 Posts
  • 0 Reply Likes
Nope. Didn't work. It's 2am here, so I'll shelve it for now, and in the morning do a complete uninstall/reinstall/patch and then report back.
Photo of RynGarcia

RynGarcia

  • 5 Posts
  • 0 Reply Likes
Very strange Chad. I am using Win7 Ultimate 64bit and it worked perfectly for me the first try.
Photo of

  • 20 Posts
  • 0 Reply Likes
Works perfectly on Win7 Professional. Well, last.fm didn't, but the fix did. you get what I mean.

thanks for the solution!
Photo of Chad

Chad

  • 20 Posts
  • 0 Reply Likes
No dice. I did a complete uninstall of Songbird. Reinstalled Songbird 1.7.2 and deleted/replaced the sbLastFM.js found in C:\Users\my_username\AppData\Roaming\Songbird2\Profiles\default_profile\extensions\audioscrobbler@songbirdnest.com\components

When I try to log in to Last.FM, I get nothing but a spinning wheel. Nothing even shows up in the Error Console. Update: This shows up in the error console:

Error: xml is null
Source File: file:///C:/Users/my_username/AppData/Roaming/Songbird2/Profiles/default_profile/extensions/audioscrobbler@songbirdnest.com/components/sbLastFm.js
Line: 1886

The same error is encountered on Line: 1899

Please help.
Photo of behzad.shabani

behzad.shabani

  • 8 Posts
  • 0 Reply Likes
working well on songbird 1.7.2 ubuntu 10.04 ;).
Photo of RynGarcia

RynGarcia

  • 5 Posts
  • 0 Reply Likes
Chad try this, it worked for me perfectly.

1. Change the name from audioscrobbler-1.0.3.1667.xpi to audioscrobbler-1.0.3.1667.xpi.zip.
2. Open the archive with 7zip or winrar and delete the sbLastFM.js then drag the new sbLastFM.js into the archive window. It will then ask you if you want to add the file to the archive, hit yes.
3. Then change the name back to audioscrobbler-1.0.3.1667.xpi.
4. Install the addon in Songbird
Photo of

  • 20 Posts
  • 0 Reply Likes
RynGarcia, I don't think that's how it needs to be done. I didn't have to do anything that complicated on my Windows 7 Professional x64 machine. All I had to do was download the file(in Internet Explorer since Chrome and Firefox both only downloaded it as a text file), cut&paste out the original file(found in the described folder) into a backup folder(just in case), paste in the new one, and start Songbird.(Songbird was closed during this process). Your steps may work, but they are way more complicated than is needed.
Photo of Chad

Chad

  • 20 Posts
  • 0 Reply Likes
RynGarcia, rougegoat is right. That's exactly what I did on my Windows XP SP3 machine and it worked perfectly.

BTW, you can still use chrome or firefox to download the file. All you need to do is remove the ".txt" on the end after you save.
Photo of RynGarcia

RynGarcia

  • 5 Posts
  • 0 Reply Likes
They are bit more complicated but they worked perfectly for me. Chad maybe try deleting the profile and creating a new one. I've had to create several different profiles over the last week. I don't know why they are getting corrupted. Chad is right, just change it to ".js" from ".txt" If you want I can upload the addon file that I already changed the file in. It's worth a shot in my opinion.
Photo of Chad

Chad

  • 20 Posts
  • 0 Reply Likes
If you look above, you'll note that I've already tried creating the new profile. I'm also on a brand new install of SongBird.

Allow me to elaborate: when I applied the patch to my XP machine, it worked exactly as expected: clicking the last.fm logo in the bottom right corner of the window opened gave me a login prompt. Logging in opened a new tab with last.fm in the window, asking me to allow SongBird access to my last.fm profile, which I granted. It then started scrobbling normally.

On my Win7 machine, I've applied the patch to a brand new install. Clicking on the last.fm icon in the bottom right of my window opens a pop-up asking me to login. Clicking login, it goes to a spinning circle icon, nothing else. No pop-up window, no login, no scrobbling.

Next test will be removing songbird from my last.fm profile settings, and trying again.

Update: well, that didn't work, either.
Photo of Chad

Chad

  • 20 Posts
  • 0 Reply Likes
Bugger. Just upgraded to 1.7.3. Same situation; same result. Error received in Error Console is this:

[last-fm] handshake got not enough lines: ["BADAUTH", ""]
Photo of Marius Jigoreanu

Marius Jigoreanu

  • 2 Posts
  • 0 Reply Likes
try updating the extension as well. for me worked fine without the need to update the extension. maybe something is messed up. try cleaning the folders (Roaming\) if it doesn't do it by itself, and reinstall.
Photo of soullessonegamereplays

soullessonegamereplays

  • 13 Posts
  • 0 Reply Likes
To everyone: I couldn't download this file while using Firefox. I suggest using Internet Explorer because that works.

Thanks Alfred, this works like a charm! You made my day!

On another note: Do we need to reput the 'original' file whenever Songbird or the Last.fm application updates or don't we need to worry anymore about this issue?

Thanks!
Photo of alfred

alfred

  • 459 Posts
  • 192 Reply Likes
The Last.fm addon update will carry the fix. So no need to redo the file replacement any more.
Photo of Leo

Leo

  • 3 Posts
  • 0 Reply Likes
I've been having the same problem with Songbird 1.4.3. Is this fix going to become available for that version also?
Photo of alfred

alfred

  • 459 Posts
  • 192 Reply Likes
You can try with the above steps anyway. But since the fix is not in the 1.4 branch, it's not sure whether that can fix the problem for 1.4 users.