I’m frustrated

Songbird fails to start on some Linux systems due to gstreamer-python

On 32-bit Fedora 11, I get the following, running Songbird 1.2:
./songbird

(songbird-bin:2782): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstdeinterlace.so': /usr/lib/gstreamer-0.10/libgstdeinterlace.so: undefined symbol: gst_video_format_parse_caps_interlaced
././songbird-bin: symbol lookup error: /usr/lib/python2.6/site-packages/gst-0.10/gst/_gst.so: undefined symbol: gst_xml_get_type
Could not initialize GStreamer: Error re-scanning registry , child terminated by signal

I'd seen some references to removing libvisual-plugins; this package is not installed on my system. Prior Songbird versions worked great; I upgraded to 1.2 today, and immediately experienced the problem. The Fedora gstreamer-plugins package was updated on 6/16; I'm guessing there's an incompatibiliy between the Fedora update and Songbird. Here's the Fedora package info:
gstreamer-plugins-good-0.10.15-1.fc11.i586
Songbird worked after this upgrade, until the update to 1.2 just a bit ago..
115 people have
this problem
+1
This topic is no longer open for comments or replies.
next » « previous
next » « previous