I’m concerned

Orchestral Companion Strings - 1yr old macbook has audio system overload

I have not had this problem until installing and using this plugin. I have 8 gb of ram and an ssd with room so I can't figure out why it should be doing this.

On my production (first used with this product) it is happening mostly right after the first second of sound. I've increased the buffer to max 1024 and even eliminated the extra tracks not being used.

All that accomplished is playing the first few bars now happens and then it stops with the error:

System Overload.
The audio engine was unable to process all required data in time.
You can try increasing the I/O buffer size, change the Multithreading option at Logic Pro X > Preferences > Audio > Devices.

On the LCD, the CPU meter starts out around 33% and then spikes all the way to max and the playback stops with the error. I've messed around with the audio settings and can't seem to find the issue. And this is a modern MacBook Pro so it should work I think.

Thanks for any help!
MacBook Pro (13-inch, 2017, Two Thunderbolt 3 ports)
RAM: 8 GB 2133 MHz LPDDR3
OS: Mojave 10.14.3
1 person has
this question
+1
Reply
  • As a follow up, I tried stacking the tracks in Logic Pro X and the song now plays but at the same point where it used to halt, it cuts out very briefly and then shows this error:
    Error while trying to synchronize Audio and MIDI.
    Sample Rate 42,474 recognized.
    Check conflict between Logic Pro X and external device.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned

  • Hi Kyle,

    Thanks for the post. Every recording program has an options, settings or preferences page where the user can adjust the buffer size. Buffer size governs the amount of time the computer is given to respond to requests (for audio processing in this case). The larger the buffer size, the more time the computer has to respond. Large buffer sizes allow the computer to handle more work without choking. This prevents pops, clicks, chattering and skipping caused by an overloaded processor, but at the cost of higher latency. Smaller buffer sizes reduce the overall amount of work the computer can handle, but it can do so with lower latency. Latency refers to the time it takes the computer to respond to input. If latency is high, signals routed into the computer and back out to speakers or headphones may be audibly delayed.

    Refer to this helpful article here regarding how to optimizing your system, improve performance, and manage latency.

    I hope this helps!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned

  • Understood and thank you!

    The issue seems to be that I have it set to the highest it will allow me which is 1024. I also had to set the voices in the synth to 4.

    Is the buffer size option based on the system it is in or is it a static set of choices?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned

  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned