Old Airport Extreme with new cable modem?

  • Question
  • Updated 4 years ago
My Airport Extreme (802.11g, white dome model, about 4.5 years old) doesn't seem to want to work with my cable provider's Motorola SB5100 cable modem and my Macbook (May 2010 vintage) running 10.6.6. Is there some way I can discover whether there's a hardware or software incompatibility, or just a human doofus problem?

My Airport Utility software sees the AE and confirms all its settings (from when I used it with a G4 iBook), but the AE doesn't pass the Internet DHCP settings from the cable modem to the Macbook, which works fine directly connected to the modem via ethernet cable.
Photo of steve lockwoodSL

steve lockwood

  • 5 Posts
  • 0 Likes

Posted 4 years ago

  • 2
Photo of Glenn Fleishman

Glenn Fleishman, Employee

  • 35 Posts
  • 10 Likes
Your AirPort Extreme should be set to Sharing -> Off (Bridge Mode) in the Internet tab. Is it? That allows DHCP passthrough.
Photo of steve lockwoodSL

steve lockwood

  • 5 Posts
  • 0 Likes
Thanks for answering. My 10.6.6 no longer has an AirPort Admin Utility which has the tabs you mention. All it has is AirPort Utility, which doesn't seem to have these tabs. Now what?
Photo of steve lockwoodSL

steve lockwood

  • 5 Posts
  • 0 Likes
You're a genius! I just tried the "manual" controls in my AirPort utility and voila: there was an Internet tab with Bridge Mode. Selecting it gave me the IP from the cable modem, and I'm sending you this thank-you from my now active wifi network.

Guess I'll be buying some more Take Control books, since I won't have to buy a new base station. ;-)
Photo of Glenn Fleishman

Glenn Fleishman, Employee

  • 35 Posts
  • 10 Likes
Hurray! Ah, I'm sorry. I have been using AirPort Utility so long, I forget that there's a wizard and an Advanced view. Glad it worked!
Photo of Adam C. Engst

Adam C. Engst, Publisher

  • 132 Posts
  • 29 Likes
What I think Glenn is pointing out is that if your cable modem is acting as the gateway and handing IP assignment, you don't want the AirPort doing it as well - hence bridge mode. Or, it might be possible to turn off that feature in the cable modem such that the AirPort gets one IP address from it, and then does DHCP on its own.
Photo of steve lockwoodSL

steve lockwood

  • 5 Posts
  • 0 Likes
Thanks for the clarification. Is there a way to access the Bridge Mode setting without the AirPort Admin utility, which is no longer part of 10.6.6 (at least it's not on my MacBook)? All I have is the AirPort Utility.app (version 5.5.2).
Photo of steve lockwoodSL

steve lockwood

  • 5 Posts
  • 0 Likes
Found it—under manual controls in the AirPort utility.app. Thanks for your help!
Photo of Adam C. Engst

Adam C. Engst, Publisher

  • 132 Posts
  • 29 Likes
Annoying how Apple changes the names of utilities sometimes, isn't it?
Photo of Chris Hankins

Chris Hankins

  • 1 Post
  • 0 Likes
not sure if anyone will see this as the thread is a year old, but I'm having the same issue. EXCEPT... when i change the settings to bridge mode, i get an alert that my ethernet is unplugged. Of course, it's not, but it thinks it is. I can't remedy... and ideas? Thanks!
Photo of Glenn Fleishman

Glenn Fleishman, Employee

  • 35 Posts
  • 10 Likes
I wish I had a solution for this, but I haven't heard the problem. One suggestion would be to use AirPort Utility to save the current configuration, then perform a factory reset, load the configuration back, and see if that clears the condition. It's just possible there's a flash corruption or some similar situation that's caused the issue.