user/movie does not exist / wrong api-key

  • Problem
  • Updated 4 years ago
  • Solved
Every now and then, I get user does not exist when checking the webpage.
I also get the same for movies (although, maybe not as often)

I also get incorrect api-key both with a script I'm using and with the official addon.

I'm guessing all of these errors are the same.

These errors show maybe 1% of times. And it always work ok when I reload the page.
Photo of kju

kju

  • 130 Posts
  • 5 Likes

Posted 4 years ago

  • 3
Photo of ltfearme

ltfearme

  • 403 Posts
  • 99 Likes
I have noticed on the rare occasion the 'user does not exist' error as well.
Photo of Justin

Justin, Founder

  • 2141 Posts
  • 212 Likes
I have also noticed this. We're trying to track down the issue and fix it. Further optimizations on the server side is the likely fix.
Photo of kju

kju

  • 130 Posts
  • 5 Likes
I've been getting this a lot lately. Especially frustrating when it's trying to scrobble.

Seems like the entire database is empty or unavailable
Photo of Justin

Justin, Founder

  • 2141 Posts
  • 212 Likes
Yep, I am looking into the performance issues this weekend. The database is getting hit pretty hard these days which is causing the issue you see above.
Photo of Alexander Iliev

Alexander Iliev

  • 17 Posts
  • 0 Likes
for me http://trakt.tv is showing blank page... :( And sometimes I have problems scrobbling from XBMC... :(
Photo of kju

kju

  • 130 Posts
  • 5 Likes
I like the new error messages!

At least now it says "server is over capacity" instead of "wrong api key" :)
Photo of Justin

Justin, Founder

  • 2141 Posts
  • 212 Likes
These issues should be fixed. Made some big optimizations to the site and so far so good.

Also added better error pages on the website in the case of a server overload or 404 error. The API will also return an error status in both cases as you discovered.
Photo of kju

kju

  • 130 Posts
  • 5 Likes
Don't know if you read topics that are solved....
but there are still performance issues.

Since I have a script that polls the api once every three minutes I get alerts on all the failures...
19:42
21:21
21:27
All times are CET.

Still a lot better than before. :)