I’m frustrated

Audio issues on Tru App for Desktop?

I have no audio, I tried to make 2 phone calls, I could see the timer running as my money dropped down from my account balance, but I couldn't hear a thing from the other side. I can hear when I click on the screen pad to dial the destination phone number, but then I have no sound. My balance dropped down from 10.00 to 9:54, so I guess I was charged for those 2 -for me- unsuccesful attempts.
I tried the echo test with the same result. There's no help in your FAQ questions, other than the echo test suggested, which, by the way, doesn't suggest what to do when it fails.
2 people have
this question
+1
This topic is no longer open for comments or replies.
  • Hi Luis,

    Sorry to hear that you are experiencing audio issues.

    First of all, thank you for trying the echo test. We advise this as a first step as this confirms where the problem resides. Hearing no audio on the echo test confirms that either a router or software firewall on your network is blocking or mis-routing the Tru audio data (I am presuming your speakers/mic are configured correctly?).

    Things you can try...

    1. Restart your modem/router
    2. Ensure that you’re not connecting to the internet through a proxy
    3. Ensure that your router does not have a SIP ALG enabled
    4. Ensure that your router firewall is not blocking RTP ports 10000-20000
    5. Ensure that your computer firewall is not blocking RTP ports 10000-20000

    For a little more information on configuring your software firewall(s) and router I would advise you to take a look at the 'Router' and 'Firewall' sections on the following page...

    http://www.truphone.com/en/Help/Tru-A...

    NB: If you have a laptop, the best way find out if the problem relates to router or software firewall, would be to try connecting at a different location. If the echo test works elsewhere you know the problem is router related.

    All the best
    Dave
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • Hi Dave
    I have the same problem - the App running on my PC makes the login sound but when I do the echo test I hear nothing.

    I have run the app on my laptop, which connects wirelessly to a different router but both routers connect to the internet via the same router modem, and on the laptop it works fine.

    Clearly the router modem is setup correctly. I have made sure the firewalls in the other routers are disabled and have disabled the software firewall in the PC and still no sound on echo test. Can not find any reference in the routers to any SIP ALG.

    Both laptop and the PC running WIN XP Pro.

    Any ideas?

    BTW I was disappointed to note that this App doesn't tell you when friends are on line, or at least it does not tell me when my Nokia is on line with the Tru App for it. :-((
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • Hi Mike

    I assume that your microphones and speakers are configured correctly within Windows. Also, please check that you have the latest version of Java installed on both your PCs (www.java.com). In addition, could you tell me if you are running the 32 bit or 64 bit versions of Windows on both PCs.

    This will rule out any issue to do with both PCs

    Regards,
    Phil
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • Hi Phil
    As I said the speakers work fine when the app. signs in and makes the short sign in jingle. Both mic and peakers work fine with Skype :-)
    Not sure how one is meant to configure which audio output/input device the TRuApp will use: e.g. head phones or PC speakers for output?

    I had to get the latest version of JAVA to get the app to log in, so yes I have it.

    Both WinXP are 32bit - the PC is service pack 3 and I guess the laptop is the same.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • Hi Mike

    I am sorry to hear you are still having a problem with the sound on the Tru App.

    Would it be possible to try connecting the Laptop to a completely different wireless network which is not connected to the router modem that you mentioned. This way we can find out whether this is a problem with the network you are using.

    For full functionality, the Tru App requires that access on the following remote ports is not restricted: TCP Port 5222, UDP Port 5062, TCP Ports 80, and TCP 443. Please check that these ports are not blocked.

    Regards,
    Phil
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • I know that the LAPTOP works, via the wireless connection, through the router modem.

    I have now tested by cabling the LAPTOP to the same switch/router that the PC which has the problem is connected. The LAPTOP still worked. This would appear to suggest that the problem is to do with the PC itself.

    This does not appear to be a firewall issue as I have tested with the firewall disabled and I have checked that the windows firewall is OFF as well.

    Any ideas?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited