Adding Search to Blog

  • Question
  • Updated 2 years ago
  • Answered
I am new to blogging, very new, and have been trying to add "search" to my blog all evening. Everytime I add the search from content I get 3 options. I want my viewers to be able to search but that a little over kill. What am I doing wrong?
I spent 4 hours on the issue, but I'm lost...I haven't even been able to post yet.

fullplatereview

  • 6 Posts
  • 0 Likes

Posted 2 years ago

  • 1

myloveforyou, Champion

  • 26 Posts
  • 5 Likes
Are they three of the exact same search modules?

fullplatereview

  • 6 Posts
  • 0 Likes
no they are all different. but there is no option, that I could find to filter or pick just one

myloveforyou, Champion

  • 26 Posts
  • 5 Likes
Can you send a screenshot? If you are on Typepad...you can hover over the modules and delete from the content area. But I am not sure what platform you are on. So a screenshot would be helpful ;)

fullplatereview

  • 6 Posts
  • 0 Likes
I think I need to clarify...when I place the search option onto my page, there is only one added, but when I view my blog there are three searches that are all different. I tried doing screen shots, I'll keep working on that but I have a few other glitches too.

myloveforyou, Champion

  • 26 Posts
  • 5 Likes
Ok, I am pretty new to these forums but have been on Typepad since 2006...so let's see if I can help. ;)

I have attached a screenshot of my content area. I have highlighted the buttons where you can "x" out content modules you do not want. Does this area look familiar to you?

Also what kind of computer are you on & what browser do you use? Let's figure this out!

Kymberlie, Official Rep

  • 996 Posts
  • 35 Likes
Hi there,

Thank you for helping out your fellow TypePad users! We appreciate you stepping up and making your community a better place, so please open a help ticket within your account and link to this post. We’ll then credit your account with some free TypePad time.

Thanks,
Kymberlie

myloveforyou, Champion

  • 26 Posts
  • 5 Likes
oh, will do! thank you!

fullplatereview

  • 6 Posts
  • 0 Likes
I was only given one "search" which I added.at something similar to this stage. Then when I viewed my blog, three different "search" options were visible.
I just started yesterday so you've been at this for ages to me...lol!
could it be that I was taking a short cut using a template?
I'm using windows & google chrome
thanks...

myloveforyou, Champion

  • 26 Posts
  • 5 Likes
Hmmm, No I don't think you took a short cut...So you added one search module & then 3 appeared but when you go back to the Content area there is only one? That sounds like it might be a bug if I am understanding correctly. I would suggest you file a Help ticket - or maybe a Typepad employee will weigh in.

Good luck blogging! Keep at it, you will figure it out!

Jeff Reine

  • 37 Posts
  • 4 Likes
Thanks for being such a great champion!

myloveforyou, Champion

  • 26 Posts
  • 5 Likes
:) No problem, I do community support for work...and love blogging. So I am happy to help someone new who seems pretty stoked to be blogging. :)

Jen, Typepad Support Engineer

  • 698 Posts
  • 45 Likes
Hi fullplatereview! What is the web address URL for the blog where you are seeing multiple search modules displayed? When I look at the blogs in your account, I'm only seeing one search module in the sidebar. If you can let us know the URL for your blog, we can take a closer look. Thanks!

Angelia Hansen

  • 3 Posts
  • 0 Likes
I see the multiple searches on my actual blog page. It is when I preview, perhaps I need to look from another engine.

Angelia Hansen

  • 3 Posts
  • 0 Likes
ok, from the above display posted by 'myloveforyou' all that is correct, I asked for one search but on my blog page there are 3 search options...one with an empty box (I assume that is supposed to be the looking glass one), one with a white box with the word search, and one with a grey box and the word search. http://fullplatereview.typepad.com

Jen, Typepad Support Engineer

  • 698 Posts
  • 45 Likes
When I check the Full Plate Review blog, only one search box is displaying. Here's a screenshot of your blog:



If you are still seeing multiple search fields, go to http://fullplatereview.typepad.com/ in your browser and clear your browser's cache by keying Ctrl+F5. It's possible that you're experiencing a browser caching issue, so your web browser is showing you a saved version of your blog from your computer hard drive rather than the newest version.

Did that help?

Angelia Hansen

  • 3 Posts
  • 0 Likes
then what am I seeing in the screen shot? to me that looks like three different ways of searching...on the bottom left panel...

Jen, Typepad Support Engineer

  • 698 Posts
  • 45 Likes
There is only one Search option on your blog. You enter the term you want to search for in the field below the Search heading and click the Search button to reveal the search results.

You can try out the same search module on the TypePad blog at: http://blairpeter.typepad.com/ Enter your search term in the field at the top of the left column and click Search to see how it works.

Is this not how you expect the search module to work?

You can use the Custom CSS feature to customize the Search module if you want to hide the Search heading. We have tips for customizing the search module here:
http://help.typepad.com/search.html

Jeff Reine

  • 37 Posts
  • 4 Likes
Welcome to TypePad, Angelia!